summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Kokot <peterkokot@gmail.com>2019-07-11 02:00:51 +0200
committerPeter Kokot <peterkokot@gmail.com>2019-07-11 02:00:51 +0200
commita6daded1a4b7d715d9b1585fe9df269ca73e2bac (patch)
treef08e3176c249071793c35fdc76568c3e870d3a0b /configure.ac
parentd63fdced2e9bc2aa6c0e07958b8991e7f222de50 (diff)
downloadphp-git-a6daded1a4b7d715d9b1585fe9df269ca73e2bac.tar.gz
Refactor undefining PACKAGE_* symbols
Instead of patching configuration headers template generated by the given tools - autoheader, this moves patching these symbols to the configure step before creating and invoking the config.status and before the configuration header file is generated from the patched template. Closes GH-4374
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bed45e7bfe..e4ff616306 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,6 +27,7 @@ PHP_CONFIG_NICE(config.nice)
PHP_CANONICAL_HOST_TARGET
AC_CONFIG_HEADERS([main/php_config.h])
+
AH_TOP([
#ifndef PHP_CONFIG_H
#define PHP_CONFIG_H
@@ -1585,6 +1586,9 @@ $PHP_OUTPUT_FILES"
dnl Generate build files.
AC_CONFIG_FILES([$ALL_OUTPUT_FILES])
+
+AC_CONFIG_COMMANDS_PRE([PHP_PATCH_CONFIG_HEADERS([main/php_config.h.in])])
+
AC_CONFIG_COMMANDS([default],[
cat <<X