summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikita Popov <nikita.ppv@gmail.com>2019-10-31 11:27:53 +0100
committerNikita Popov <nikita.ppv@gmail.com>2019-10-31 11:27:53 +0100
commitedccf32f7f36a8bc759b9482737e0c3efcb3a005 (patch)
treef5e10ad5c6c8349d0975d4267efefb6f98ccfeff /configure.ac
parent333d607d47ca6eec96637c1c8686591dec6f5a0b (diff)
downloadphp-git-edccf32f7f36a8bc759b9482737e0c3efcb3a005.tar.gz
Remove configure checks for supported instruction sets
These were checking whether the instruction set is supported by the host CPU, however they were only used to condition on whether this instruction set is targeted at all. It would still use dynamic dispatch (e.g. based on ifunc resolvers) to select the actual implementation. Whether the target is guaranteed to support the instruction set without dispatch is determined based on pre-defined macros like __SSE2__. This removes the configure-time builtin cpu checks to remove confusion. Additionally this allows targeting an architecture that is newer than the host architecture.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 038a3fbb9f..39dc519a6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -541,12 +541,6 @@ PHP_CHECK_BUILTIN_CPU_INIT
dnl Check __builtin_cpu_supports
PHP_CHECK_BUILTIN_CPU_SUPPORTS
-dnl Check instructions.
-PHP_CHECK_CPU_SUPPORTS([ssse3])
-PHP_CHECK_CPU_SUPPORTS([sse4.2])
-PHP_CHECK_CPU_SUPPORTS([avx])
-PHP_CHECK_CPU_SUPPORTS([avx2])
-
dnl Check for structure members.
AC_CHECK_MEMBERS([struct tm.tm_gmtoff],,,[#include <time.h>])
AC_CHECK_MEMBERS([struct stat.st_blksize, struct stat.st_rdev])