summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAntony Dovgal <tony2001@php.net>2006-12-25 15:40:14 +0000
committerAntony Dovgal <tony2001@php.net>2006-12-25 15:40:14 +0000
commit8fd11f3d26ceb41becdc30be924820ea2a3cc1e9 (patch)
tree9e5e73eed6098d9d9aec2fcb8a9c597630704ade /configure.in
parent03aea51026664ae9171c517858cc0031a06d9552 (diff)
downloadphp-git-8fd11f3d26ceb41becdc30be924820ea2a3cc1e9.tar.gz
fix bug #39890 (using autoconf 2.6x and --with-layout=GNU breaks PEAR install path)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5e2efd5b0b..41c1e22a18 100644
--- a/configure.in
+++ b/configure.in
@@ -1052,6 +1052,15 @@ if test -z "$EXTENSION_DIR"; then
fi
fi
+case $PHP_LAYOUT in
+ GNU)
+ datarootdir=$prefix/share
+ ;;
+ *)
+ datarootdir=$prefix/php
+ ;;
+esac
+
dnl Expand all directory names for use in macros/constants
EXPANDED_EXTENSION_DIR=`eval echo $EXTENSION_DIR`
EXPANDED_LOCALSTATEDIR=`eval echo $localstatedir`
@@ -1141,6 +1150,7 @@ PHP_SUBST(phptempdir)
PHP_SUBST(prefix)
PHP_SUBST(localstatedir)
PHP_SUBST(datadir)
+PHP_SUBST(datarootdir)
PHP_SUBST(sysconfdir)
PHP_SUBST(EXEEXT)