summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAntony Dovgal <tony2001@php.net>2006-09-25 11:05:29 +0000
committerAntony Dovgal <tony2001@php.net>2006-09-25 11:05:29 +0000
commited4cd4c75016b1d7be1451178f80497e6718ce8f (patch)
treebd66e6e8e04fd6cfe9523bc4d5c83031f89803c1 /configure.in
parentc5108cf86d75609dfb72d9643ba4a08a02b1247e (diff)
downloadphp-git-ed4cd4c75016b1d7be1451178f80497e6718ce8f.tar.gz
change CXXFLAGS along with CFLAGS as there might be C++ code
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6dbdec23c8..699e00f01c 100644
--- a/configure.in
+++ b/configure.in
@@ -663,10 +663,12 @@ if test "$PHP_GCOV" = "yes"; then
dnl Remove all optimization flags from CFLAGS
changequote({,})
CFLAGS=`echo "$CFLAGS" | $SED -e 's/-O[0-9]*//g'`
+ CXXFLAGS=`echo "$CXXFLAGS" | $SED -e 's/-O[0-9]*//g'`
changequote([,])
dnl Add the special gcc flags
CFLAGS="$CFLAGS -O0 -fprofile-arcs -ftest-coverage"
+ CXXFLAGS="$CXXFLAGS -O0 -fprofile-arcs -ftest-coverage"
fi
PHP_ARG_ENABLE(debug, whether to include debugging symbols,
@@ -677,8 +679,10 @@ if test "$PHP_DEBUG" = "yes"; then
ZEND_DEBUG=yes
changequote({,})
CFLAGS=`echo "$CFLAGS" | $SED -e 's/-O[0-9]*//g'`
+ CXXFLAGS=`echo "$CXXFLAGS" | $SED -e 's/-O[0-9]*//g'`
changequote([,])
CFLAGS="$CFLAGS -O0"
+ CXXFLAGS="$CXXFLAGS -O0"
else
PHP_DEBUG=0
ZEND_DEBUG=no