summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJani Taskinen <jani@php.net>2007-10-05 12:34:48 +0000
committerJani Taskinen <jani@php.net>2007-10-05 12:34:48 +0000
commit69bea4d736d735b946a38723f0c68925c2cf37fa (patch)
tree7d5397056c5f400c03f661205e659c7696ba21e5 /configure.in
parentfd841a44db9bcc0d6a0193a30b64f20a78064ce9 (diff)
downloadphp-git-69bea4d736d735b946a38723f0c68925c2cf37fa.tar.gz
- Sync with configure.in from HEAD (the CGI stuff is as ini options nowadays)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 2 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index d44a06eb80..cfd75176df 100644
--- a/configure.in
+++ b/configure.in
@@ -1296,12 +1296,12 @@ PHP_INSTALL_HEADERS([Zend/ TSRM/ include/ main/ main/streams/ regex/])
PHP_ADD_SOURCES(TSRM, TSRM.c tsrm_strtok_r.c tsrm_virtual_cwd.c)
-PHP_ADD_SOURCES(main, main.c snprintf.c spprintf.c getopt.c php_sprintf.c \
+PHP_ADD_SOURCES(main, main.c snprintf.c spprintf.c php_sprintf.c \
safe_mode.c fopen_wrappers.c alloca.c php_scandir.c \
php_ini.c SAPI.c rfc1867.c php_content_types.c strlcpy.c \
strlcat.c mergesort.c reentrancy.c php_variables.c php_ticks.c \
network.c php_open_temporary_file.c php_logos.c \
- output.c )
+ output.c getopt.c)
PHP_ADD_SOURCES(main/streams, streams.c cast.c memory.c filter.c \
plain_wrapper.c userspace.c transports.c xp_socket.c mmap.c)
@@ -1435,21 +1435,6 @@ dnl fi
echo "| and make the changes described there and try again. |"
fi
- # Warn about CGI version with no extra security options.
- if test "$PHP_SAPI" = "cgi"; then
- if test "$PHP_FORCE_CGI_REDIRECT" = "no" && test "$PHP_DISCARD_PATH" = "no"; then
- echo "+--------------------------------------------------------------------+"
- echo "| *** WARNING *** |"
- echo "| |"
- echo "| You will be compiling the CGI version of PHP without any |"
- echo "| redirection checking. By putting this cgi binary somewhere in |"
- echo "| your web space, users may be able to circumvent existing .htaccess |"
- echo "| security by loading files directly through the parser. See |"
- echo "| http://www.php.net/manual/security.php for more details. |"
- fi
- fi
-
-
if test -n "$DEBUG_LOG"; then
rm -f config.cache
cat <<X