summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMarcus Boerger <helly@php.net>2008-02-17 20:50:03 +0000
committerMarcus Boerger <helly@php.net>2008-02-17 20:50:03 +0000
commit2633dcab4648bb8120096a29fa291237510d4808 (patch)
treedc18e7fd14459191ef7c4889e5e854604f2bd051 /configure.in
parent22392affefd36c47876f23157e7539e51fea6805 (diff)
downloadphp-git-2633dcab4648bb8120096a29fa291237510d4808.tar.gz
- MFH Allow zend_extensions to be build inside ext and tested with 'make test'
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index e5dff11c71..5bfc663c3d 100644
--- a/configure.in
+++ b/configure.in
@@ -899,7 +899,7 @@ enable_static=yes
case $php_build_target in
program|static)
standard_libtool_flag='-prefer-non-pic -static'
- if test -z "$PHP_MODULES"; then
+ if test -z "$PHP_MODULES" && test -z "$PHP_ZEND_EX"; then
enable_shared=no
fi
;;
@@ -1166,6 +1166,7 @@ PHP_SUBST(PHP_CLI_OBJS)
PHP_SUBST(PHP_GLOBAL_OBJS)
PHP_SUBST(PHP_MODULES)
+PHP_SUBST(PHP_ZEND_EX)
PHP_SUBST(EXT_LIBS)
@@ -1247,6 +1248,17 @@ if test "$PHP_THREAD_SAFETY" = "yes" && test "$PHP_MYSQL" = "yes"; then
CPPFLAGS="$CPPFLAGS -DTHREAD=1"
fi
+if test "$PHP_DEBUG" = "yes" && test "$PHP_THREAD_SAFETY" = "yes; then
+ZEND_EXT_TYPE="zend_extension_debug_ts"
+elif test "$PHP_DEBUG" = "yes"; then
+ZEND_EXT_TYPE="zend_extension_debug"
+elif test "$PHP_THREAD_SAFETY" = "yes; then
+ZEND_EXT_TYPE="zend_extension_ts"
+else
+ZEND_EXT_TYPE="zend_extension"
+fi
+PHP_SUBST(ZEND_EXT_TYPE)
+
dnl
dnl Libtool creation
dnl
@@ -1283,7 +1295,7 @@ CFLAGS="\$(CFLAGS_CLEAN) $standard_libtool_flag"
INLINE_CFLAGS="$INLINE_CFLAGS $standard_libtool_flag"
CXXFLAGS="$CXXFLAGS $standard_libtool_flag"
-all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_CLI_TARGET)"
+all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_CLI_TARGET)"
install_targets="$install_modules install-build install-headers install-programs $install_pear"
case $PHP_SAPI in