summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRasmus Lerdorf <rasmus@php.net>2009-11-28 17:56:03 +0000
committerRasmus Lerdorf <rasmus@php.net>2009-11-28 17:56:03 +0000
commit6961cd023a5e637e7f1e252a3bf36de2225611a7 (patch)
tree8d969979ce337cdab235ffbbe0cb4c5ea763bce5 /configure.in
parentc4d350632b05ddf44535a7c4192c1b06e95c1961 (diff)
downloadphp-git-6961cd023a5e637e7f1e252a3bf36de2225611a7.tar.gz
Ok, new attempt. Require autoconf-2.60 in this branch.
This simplifies things quite a bit by entirely getting rid of the m4 diversions which were messing things up. Now we are using the built-in autoconf diversions the way they were intended and the HELP output order is preserved through the AC_PRESERVE_HELP_ORDER macro which was introduced in autoconf-2.59c The next thing to clean up are the template warnings and I want to get to the bottom of the cache warning we generate as well. Now that I fixed the _cv_ stuff, I am not sure that is still a valid warning.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in46
1 files changed, 2 insertions, 44 deletions
diff --git a/configure.in b/configure.in
index 95ca1bd15f..bb98fe009a 100644
--- a/configure.in
+++ b/configure.in
@@ -1,28 +1,6 @@
## $Id$ -*- autoconf -*-
dnl ## Process this file with autoconf to produce a configure script.
-divert(1001)
-
-dnl ## Diversion 1 is the autoconf + automake setup phase. We also
-dnl ## set the PHP version, deal with platform-specific compile
-dnl ## options and check for the basic compile tools.
-
-dnl ## Diversion 2 is the initial checking of OS features, programs,
-dnl ## libraries and so on.
-
-dnl ## In diversion 3 we check for compile-time options to the PHP
-dnl ## core and how to deal with different system dependencies.
-dnl ## This includes whether debugging or short tags are enabled
-dnl ## and the default behaviour of php.ini options.
-dnl ## This is also where an SAPI interface is selected (choosing between
-dnl ## Apache module, CGI etc.)
-
-dnl ## In diversion 4 we check user-configurable general settings.
-
-dnl ## In diversion 5 we check which extensions should be compiled.
-dnl ## All of these are normally in the extension directories.
-dnl ## Diversion 5 is the last one. Here we generate files and clean up.
-
dnl include Zend specific macro definitions first
dnl -------------------------------------------------------------------------
sinclude(Zend/acinclude.m4)
@@ -30,7 +8,8 @@ sinclude(Zend/acinclude.m4)
dnl Basic autoconf + automake initialization, generation of config.nice.
dnl -------------------------------------------------------------------------
-AC_PREREQ(2.13)
+AC_PREREQ(2.60)
+AC_PRESERVE_HELP_ORDER
AC_INIT(README.SVN-RULES)
PHP_CONFIG_NICE(config.nice)
@@ -304,16 +283,6 @@ sinclude(Zend/Zend.m4)
sinclude(TSRM/threads.m4)
sinclude(TSRM/tsrm.m4)
-
-divert(1002)
-
-dnl ## Diversion 2 is where we set PHP-specific options and come up
-dnl ## with reasonable default values for them. We check for pthreads here
-dnl ## because the information is needed by the SAPI configuration.
-dnl ## This is also where an SAPI interface is selected (choosing between
-dnl ## Apache module, CGI etc.)
-
-dnl .
dnl -------------------------------------------------------------------------
PTHREADS_CHECK
@@ -344,13 +313,6 @@ if test "$enable_maintainer_zts" = "yes"; then
PTHREADS_FLAGS
fi
-divert(1003)
-
-dnl ## In diversion 3 we check for compile-time options to the PHP
-dnl ## core and how to deal with different system dependencies.
-dnl ## This includes whether debugging or short tags are enabled
-dnl ## and the default behaviour of php.ini options.
-
dnl Starting system checks.
dnl -------------------------------------------------------------------------
@@ -691,8 +653,6 @@ if test "x$php_crypt_r" = "x1"; then
PHP_CRYPT_R_STYLE
fi
-divert(1004)
-
dnl ## In diversion 4 we check user-configurable general settings.
dnl General settings.
@@ -932,8 +892,6 @@ else
AC_MSG_RESULT([using system default])
fi
-divert(1005)
-
dnl ## In diversion 5 we check which extensions should be compiled.
dnl ## All of these are normally in the extension directories.