summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJani Taskinen <jani@php.net>2009-11-30 14:08:33 +0000
committerJani Taskinen <jani@php.net>2009-11-30 14:08:33 +0000
commitd261e6f4a26a85ce539af2bb7c1d52c0780f46c3 (patch)
tree3cb5927105d43de47749de64e08b1bdaf541315c /configure.in
parent7c0803a8ca75105bf60f7658dc8e21518ca2f8e7 (diff)
downloadphp-git-d261e6f4a26a85ce539af2bb7c1d52c0780f46c3.tar.gz
- Restore configure.in before the madness started
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 24 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 788a3f0f9d..4d729fcc54 100644
--- a/configure.in
+++ b/configure.in
@@ -122,6 +122,21 @@ dnl or the contents of libs.
$php_shtool mkdir -p libs
rm -f libs/*
+dnl Darwin 9 hack
+dnl Because the default debugging format used by Apple's GCC on Mac OS 10.5
+dnl causes errors in all current and past versions of Autoconf, we do a little
+dnl messing with the CFLAGS here to trick it.
+php_did_darwin9_cheat=0
+case $host_alias in
+*darwin9*)
+ hasg=`echo $CFLAGS | grep -E '(^-g)|([[:space:]]-g)'`
+ if test x"$hasg" = "x"; then
+ php_did_darwin9_cheat=1
+ CFLAGS="$CFLAGS -gstabs"
+ fi
+ ;;
+esac
+
dnl Checks for programs.
dnl -------------------------------------------------------------------------
@@ -1324,14 +1339,6 @@ PHP_CONFIGURE_PART(Configuring libtool)
LDFLAGS="$LDFLAGS $PHP_AIX_LDFLAGS"
-dnl Autoconf 2.13's libtool checks go slightly nuts on Mac OS X 10.5 and 10.6.
-dnl This hack works around it. Ugly.
-case $host_alias in
-*darwin9*|*darwin10*)
- ac_cv_exeext=
- ;;
-esac
-
dnl Only allow AC_PROG_CXX and AC_PROG_CXXCPP if they are explicitly called (by PHP_REQUIRE_CXX).
dnl Otherwise AC_PROG_LIBTOOL fails if there is no working C++ compiler.
AC_PROVIDE_IFELSE([PHP_REQUIRE_CXX], [], [
@@ -1355,6 +1362,15 @@ SHARED_LIBTOOL='$(LIBTOOL)'
CC=$old_CC
+dnl Finish the Darwin hack
+if test "$php_did_darwin9_cheat" -eq 1; then
+ if test "$PHP_DEBUG" = "1"; then
+ CFLAGS=`echo "$CFLAGS" | $SED -e 's/-gstabs/-g/g'`
+ else
+ CFLAGS=`echo "-O2 $CFLAGS" | $SED -e 's/-gstabs//g'`
+ fi
+fi
+
PHP_CONFIGURE_PART(Generating files)
CXXFLAGS_CLEAN=$CXXFLAGS