summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorfoobar <sniper@php.net>2001-12-01 00:59:43 +0000
committerfoobar <sniper@php.net>2001-12-01 00:59:43 +0000
commit8a8741a1fea40972b6d470b4a1a82915357552ee (patch)
treef5da699c21df4729a5c57ef484463e604c14c54d /configure.in
parent80d8e554d3fe018c85dc49b138e64dfc4b017d5b (diff)
downloadphp-git-8a8741a1fea40972b6d470b4a1a82915357552ee.tar.gz
This makes the configure --help output more readable.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 297091d320..82a4cf93cf 100644
--- a/configure.in
+++ b/configure.in
@@ -141,6 +141,7 @@ sinclude(Zend/Zend.m4)
sinclude(TSRM/tsrm.m4)
divert(2)
+PHP_HELP_SEPARATOR([SAPI modules:])
PTHREADS_CHECK
@@ -467,6 +468,7 @@ if test $ac_cv_type_in_addr_t = no; then
fi
divert(4)
+PHP_HELP_SEPARATOR([General settings:])
PHP_ARG_ENABLE(debug, whether to include debugging symbols,
[ --enable-debug Compile with debugging symbols.], no)
@@ -637,6 +639,17 @@ AC_CHECK_LIB(crypt, crypt, [
])
divert(5)
+PHP_HELP_SEPARATOR([Extensions:
+
+ --with-EXTENSION=[shared[,PATH]]
+
+ NOTE: Not all extensions can be build as 'shared'.
+
+ Example: --with-foobar=shared,/usr/local/foobar/
+
+ o Builds the foobar extension as shared extension.
+ o foobar package install prefix is /usr/local/foobar/
+])
PHP_CONFIGURE_PART(Configuring extensions)
@@ -645,6 +658,9 @@ esyscmd(./scripts/config-stubs ext)
PHP_FAST_OUTPUT(sapi/$PHP_SAPI/Makefile)
+
+PHP_HELP_SEPARATOR([Other settings:])
+
AC_MSG_CHECKING([whether to enable versioning])
AC_ARG_ENABLE(versioning,
[ --enable-versioning Export only required symbols.