summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorfoobar <sniper@php.net>2003-02-11 21:11:42 +0000
committerfoobar <sniper@php.net>2003-02-11 21:11:42 +0000
commitfdba676769b835f6c05eacfd73d2d42b943196f0 (patch)
tree61a0bb68e8df4f6cb3b77deb678c5bfc265f5baf /configure.in
parentc681320471fd35dc56a27657cb0c3a0b80e1a8c4 (diff)
downloadphp-git-fdba676769b835f6c05eacfd73d2d42b943196f0.tar.gz
- Fixed some weird crashes causd by the new default behaviour
of libtool 1.4.3 - Require libtool 1.4.3 or newer from now on.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6d8ca5da0c..44b856b9f1 100644
--- a/configure.in
+++ b/configure.in
@@ -1065,6 +1065,8 @@ if test "$enable_debug" != "yes"; then
PHP_SET_LIBTOOL_VARIABLE([--silent])
fi
+dnl libtool 1.4.3 needs this.
+PHP_SET_LIBTOOL_VARIABLE([--preserve-dup-deps])
test -z "$PHP_COMPILE" && PHP_COMPILE='$(LIBTOOL) --mode=compile $(COMPILE) -c $<'
test -z "$CXX_PHP_COMPILE" && CXX_PHP_COMPILE='$(LIBTOOL) --mode=compile $(CXX_COMPILE) -c $<'