summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMoriyoshi Koizumi <moriyoshi@php.net>2003-03-29 15:54:19 +0000
committerMoriyoshi Koizumi <moriyoshi@php.net>2003-03-29 15:54:19 +0000
commitf5929a95b2cd0c32681a8fe8eed93f62900aaa9f (patch)
tree5a42b56bdc03c49300c91b74782d9e62e3173e53 /configure.in
parent20860feef10d7848bf46cc964da34925c8a31e0b (diff)
downloadphp-git-f5929a95b2cd0c32681a8fe8eed93f62900aaa9f.tar.gz
Improved bison check; now configure accepts 1.28, 1.35, and 1.75 only.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5a4de05eaa..409951de1c 100644
--- a/configure.in
+++ b/configure.in
@@ -136,8 +136,8 @@ if test "$YACC" != "bison -y"; then
else
AC_MSG_CHECKING([bison version])
set `bison --version| grep 'GNU Bison' | cut -d ' ' -f 4 | sed -e 's/\./ /'`
- if test "${1}" = "1" -a "${2}" -lt "28"; then
- AC_MSG_WARN(You will need bison 1.28 if you want to regenerate the Zend parser (found ${1}.${2}).)
+ if test "${1}" = "1" -a "(" "${2}" -lt "75" -a "${2}" -ne "28" -a "${2}" -ne "35" -o "${2}" -ge "875" ")"; then
+ AC_MSG_WARN(You will need bison 1.28, 1.35 or 1.75 if you want to regenerate the Zend parser (found ${1}.${2}).)
fi
AC_MSG_RESULT(${1}.${2} (ok))
fi