summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMarcus Boerger <helly@php.net>2003-04-02 21:17:16 +0000
committerMarcus Boerger <helly@php.net>2003-04-02 21:17:16 +0000
commita90ea73ef807e7dce424ef5f274a7d98dbab19c6 (patch)
tree9acb0f5e588c5e6c7c056dc48be8e5a0573958cc /configure.in
parent3d62a3491e8508e90bc109f3d3d984eae2f8c10a (diff)
downloadphp-git-a90ea73ef807e7dce424ef5f274a7d98dbab19c6.tar.gz
For now only bison 1.28, 1.35 and 1.75 are working properly
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index dc663ec7cb..21a237cd45 100644
--- a/configure.in
+++ b/configure.in
@@ -136,8 +136,8 @@ if test "$YACC" != "bison -y"; then
else
AC_MSG_CHECKING([bison version])
set `bison --version| grep 'GNU Bison' | cut -d ' ' -f 4 | sed -e 's/\./ /'`
- if test "${1}" = "1" -a "(" "${2}" -lt "75" -a "${2}" -ne "28" -a "${2}" -ne "35" -o "${2}" -ge "875" ")"; then
- AC_MSG_WARN(You will need bison 1.28, 1.35 or 1.75 if you want to regenerate the Zend parser (found ${1}.${2}).)
+ if test "${1}" = "1" -a "${2}" != "28" -a "${2}" != "35" -a "${2}" != "75"; then
+ AC_MSG_WARN([You will need bison 1.28, 1.35 or 1.75 if you want to regenerate the Zend parser (found ${1}.${2}).])
fi
AC_MSG_RESULT(${1}.${2} (ok))
fi