summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMarcus Boerger <helly@php.net>2002-11-15 11:49:58 +0000
committerMarcus Boerger <helly@php.net>2002-11-15 11:49:58 +0000
commit4ef6a3af039481d13692a3d1d04bcc3a9bffcce9 (patch)
tree56fbf6e9307b42721d9d41ae987e5e95823ff2fd /configure.in
parentb030a7a140077b2563efdf892a11af290abf6074 (diff)
downloadphp-git-4ef6a3af039481d13692a3d1d04bcc3a9bffcce9.tar.gz
db is deprecated now
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fa471f68b3..241ef85b7c 100644
--- a/configure.in
+++ b/configure.in
@@ -1235,6 +1235,17 @@ cat <<X
X
fi
+ if test "$PHP_DB" != "no"; then
+cat <<X
++--------------------------------------------------------------------+
+| *** WARNING *** |
+| |
+| You chose to compile PHP with DB extension. This extension is |
+| deprecated and does not support databse locking correctly. Please |
+| use DBA extension which is a full operational superset. |
+X
+ fi
+
if test "$MYSQL_MODULE_TYPE" = "builtin" && test "$PHP_SAPI" != "cgi" && test "$PHP_SAPI" != "cli" && test "$php_multiple_shlib_versions_ok" != "yes"; then
cat <<X
+--------------------------------------------------------------------+