summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNikita Popov <nikita.ppv@gmail.com>2017-02-05 18:10:04 +0100
committerNikita Popov <nikita.ppv@gmail.com>2017-02-05 18:10:04 +0100
commit70b27b5ad874953e76730322e250a7e2d3e77155 (patch)
treed872033c1f934f53c9bb2395d58b9b9bf9ca63ac /configure.in
parentb87e399393816d966703fded907f8fc8f9afa5c1 (diff)
parent9ea0949f43959ff0cf519e7a10ef9de7a538cde3 (diff)
downloadphp-git-70b27b5ad874953e76730322e250a7e2d3e77155.tar.gz
Merge branch 'PHP-7.0' into PHP-7.1
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index b6380c5cdc..452212389d 100644
--- a/configure.in
+++ b/configure.in
@@ -69,13 +69,13 @@ int zend_sprintf(char *buffer, const char *format, ...);
/* To enable the is_nan, is_infinite and is_finite PHP functions */
#ifdef NETWARE
- #define HAVE_ISNAN 1
- #define HAVE_ISINF 1
- #define HAVE_ISFINITE 1
+ #define HAVE_DECL_ISNAN 1
+ #define HAVE_DECL_ISINF 1
+ #define HAVE_DECL_ISINFINITE 1
#endif
#ifndef zend_isnan
-#ifdef HAVE_ISNAN
+#ifdef HAVE_DECL_ISNAN
#define zend_isnan(a) isnan(a)
#elif defined(HAVE_FPCLASS)
#define zend_isnan(a) ((fpclass(a) == FP_SNAN) || (fpclass(a) == FP_QNAN))
@@ -84,18 +84,18 @@ int zend_sprintf(char *buffer, const char *format, ...);
#endif
#endif
-#ifdef HAVE_ISINF
+#ifdef HAVE_DECL_ISINF
#define zend_isinf(a) isinf(a)
#elif defined(INFINITY)
/* Might not work, but is required by ISO C99 */
-#define zend_isinf(a) (((a)==INFINITY)?1:0)
+#define zend_isinf(a) (((a)==INFINITY || (a)==-INFINITY)?1:0)
#elif defined(HAVE_FPCLASS)
#define zend_isinf(a) ((fpclass(a) == FP_PINF) || (fpclass(a) == FP_NINF))
#else
#define zend_isinf(a) 0
#endif
-#if defined(HAVE_ISFINITE) || defined(isfinite)
+#if defined(HAVE_DECL_ISINFINITE) || defined(isfinite)
#define zend_finite(a) isfinite(a)
#elif defined(HAVE_FINITE)
#define zend_finite(a) finite(a)