summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJani Taskinen <jani@php.net>2007-07-12 11:33:37 +0000
committerJani Taskinen <jani@php.net>2007-07-12 11:33:37 +0000
commit921eb8939b42eb726549919ab25b8fd7d67ff992 (patch)
tree2c17d03bb083d92af0b195cb8e75047a6f4aee3d /configure.in
parent28a2fe07b487e7cbd3b920610b304fc0125f2d5b (diff)
downloadphp-git-921eb8939b42eb726549919ab25b8fd7d67ff992.tar.gz
MFH: fix invalid logic + prevent non-integers to be passed
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 0e0d967bab..cacdc7d278 100644
--- a/configure.in
+++ b/configure.in
@@ -832,9 +832,13 @@ AC_MSG_CHECKING([how big to make fd sets])
PHP_ARG_ENABLE(fd-setsize,,
[ --enable-fd-setsize Set size of descriptor sets], no, no)
-if test "$PHP_FD_SETSIZE" != "yes"; then
- CPPFLAGS="$CPPFLAGS -DFD_SETSIZE=$PHP_FD_SETSIZE"
- AC_MSG_RESULT([using $PHP_FD_SETSIZE])
+if test "$PHP_FD_SETSIZE" != "no"; then
+ if test "0$PHP_FD_SETSIZE" -gt 0 2>/dev/null; then
+ CPPFLAGS="$CPPFLAGS -DFD_SETSIZE=$PHP_FD_SETSIZE"
+ AC_MSG_RESULT([using $PHP_FD_SETSIZE])
+ else
+ AC_MSG_ERROR([Invalid value passed to --enable-fd-setsize!])
+ fi
else
AC_MSG_RESULT([using system default])
fi