summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSascha Schumann <sas@php.net>1999-09-29 22:18:43 +0000
committerSascha Schumann <sas@php.net>1999-09-29 22:18:43 +0000
commitcf4afd61f0e426e68543709de9e6faa3c3c6d936 (patch)
tree343f885309602086a81bde061d9ea29f6572f405 /configure.in
parent4db370ab9c8a728b0abe13683f1776a36be4b270 (diff)
downloadphp-git-cf4afd61f0e426e68543709de9e6faa3c3c6d936.tar.gz
* create Makefiles for ext, pcrelib, sapi/*
* copy files for Apache from $(srcdir)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index c9b3f100f3..9f4883bf39 100644
--- a/configure.in
+++ b/configure.in
@@ -706,6 +706,11 @@ AC_SUBST(EXTRA_LIBS)
# reading config stubs
esyscmd(./scripts/config-stubs ext)
+dnl if it's still the default choice, enable this implicitly
+if test "$PHP_SAPI" = "cgi"; then
+ PHP_OUTPUT(sapi/cgi/Makefile)
+fi
+
divert(4)
dnl If we are using gcc and the user has not specified CFLAGS, add -O2.
@@ -741,11 +746,8 @@ AC_SUBST(PHP_LIBS)
AC_SUBST(PHP_SAPI)
AC_SUBST(SAPI_TARGET)
-test -d sapi || mkdir sapi
-test -d ext || mkdir ext
-
#libphp4.module
-AC_OUTPUT([Makefile php4.spec $PHP_OUTPUT_FILES
+AC_OUTPUT([Makefile php4.spec ext/Makefile sapi/Makefile $PHP_OUTPUT_FILES
scripts/mkextlib regex/Makefile build-defs.h], [], [
if test ! -f $srcdir/ext/bcmath/number.c; then