summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorfoobar <sniper@php.net>2005-02-07 12:48:11 +0000
committerfoobar <sniper@php.net>2005-02-07 12:48:11 +0000
commit066d1b4d530d969fea641fed4a381d5b499341e0 (patch)
tree601d8b90861ab3204964b7a7e3e301f8ca49e4b5 /configure.in
parentdbcf51b5a80813940ee7e17e1af7f4dfbda3eb64 (diff)
downloadphp-git-066d1b4d530d969fea641fed4a381d5b499341e0.tar.gz
- Fixed bug #31858 (--disable-cli does not force --without-pear)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 10 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 3a078ab002..ff43fd56a1 100644
--- a/configure.in
+++ b/configure.in
@@ -934,6 +934,11 @@ if test -z "$with_pear" && test "$enable_pear" = "no"; then
with_pear=no
fi
+# If CLI is disabled -> disable PEAR
+if test "$PHP_SAPI_CLI" = "no"; then
+ with_pear=no
+fi
+
PHP_ARG_WITH(pear, [whether to install PEAR],
[ --with-pear=DIR Install PEAR in DIR (default PREFIX/lib/php)
--without-pear Do not install PEAR], DEFAULT, yes)
@@ -943,17 +948,13 @@ if test "$PHP_PEAR" != "no"; then
dnl
dnl PEAR dependancies
dnl
- if test "$PHP_SAPI_CLI" = "no"; then
- pear_error_msg="$pear_error_msg
- PEAR requires CLI to be enabled. Add --enable-cli to the configure line. (or --disable-pear)"
- fi
if test "$PHP_PCRE_REGEX" = "no"; then
pear_error_msg="$pear_error_msg
- PEAR requires PCRE to be enabled. Add --with-pcre-regex to the configure line. (or --disable-pear)"
+ PEAR requires PCRE to be enabled. Add --with-pcre-regex to the configure line. (or --without-pear)"
fi
if test "$PHP_XML" = "no"; then
pear_error_msg="$pear_error_msg
- PEAR requires XML to be enabled. Add --enable-xml to the configure line. (or --disable-pear)"
+ PEAR requires XML to be enabled. Add --enable-xml to the configure line. (or --without-pear)"
fi
dnl
@@ -961,7 +962,7 @@ dnl ext/xmlrpc is not really there yet to be a requirement..
dnl
dnl if test "$PHP_XMLRPC" = "no"; then
dnl pear_error_msg="$pear_error_msg
-dnl PEAR requires XML-RPC to be enabled. Add --with-xmlrpc to the configure line. (or --disable-pear)"
+dnl PEAR requires XML-RPC to be enabled. Add --with-xmlrpc to the configure line. (or --without-pear)"
dnl fi
dnl
@@ -978,6 +979,8 @@ dnl
*) PEAR_INSTALLDIR=$libdir/php;;
esac
fi
+
+ PHP_ADD_MAKEFILE_FRAGMENT($abs_srcdir/pear/Makefile.frag,$abs_srcdir/pear,pear)
fi
@@ -1327,7 +1330,6 @@ PHP_ADD_BUILD_DIR(TSRM)
PHP_ADD_BUILD_DIR(Zend)
PHP_ADD_MAKEFILE_FRAGMENT($abs_srcdir/scripts/Makefile.frag,$abs_srcdir/scripts,scripts)
-PHP_ADD_MAKEFILE_FRAGMENT($abs_srcdir/pear/Makefile.frag,$abs_srcdir/pear,pear)
PHP_ADD_MAKEFILE_FRAGMENT($abs_srcdir/Makefile.frag,$abs_srcdir/Zend,Zend)
PHP_ADD_MAKEFILE_FRAGMENT($abs_srcdir/Zend/Makefile.frag,$abs_srcdir/Zend,Zend)