summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorWez Furlong <wez@php.net>2004-12-12 16:10:35 +0000
committerWez Furlong <wez@php.net>2004-12-12 16:10:35 +0000
commitd10b86f8f42aa3625c6e89f543bade10d0c6917b (patch)
treefdbb9ec57a08002cbbcb172ca45e8803ff627630 /configure.in
parentc96a1e0ddf2a6dcf444af669f19fe65053489752 (diff)
downloadphp-git-d10b86f8f42aa3625c6e89f543bade10d0c6917b.tar.gz
Add stream_socket_pair(), a streams based version of socketpair().
Modified patch from Vincent [six at t0x dot net]
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c995a5b3d8..ac5a362307 100644
--- a/configure.in
+++ b/configure.in
@@ -322,6 +322,7 @@ dnl are usually in libnsl
dnl Also, uClibc will bark at linking with glibc's libnsl.
PHP_CHECK_FUNC(socket, socket)
+PHP_CHECK_FUNC(socketpair, socket)
PHP_CHECK_FUNC(htonl, socket)
PHP_CHECK_FUNC(gethostname, nsl)
PHP_CHECK_FUNC(gethostbyaddr, nsl)