summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJani Taskinen <jani@php.net>2007-08-06 14:33:51 +0000
committerJani Taskinen <jani@php.net>2007-08-06 14:33:51 +0000
commit67940a9c29b4f96d983c45ddc0601053b15a6905 (patch)
tree5c175caf27c3f2bc10ec4dfb10728231ce644290 /configure.in
parent83e7324daefdc5e5d4a140dd80b37232b81a1c5c (diff)
downloadphp-git-67940a9c29b4f96d983c45ddc0601053b15a6905.tar.gz
MFH:- Fixed bug #42195 (C++ compiler required always)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d493c8907c..706c0ed99c 100644
--- a/configure.in
+++ b/configure.in
@@ -1249,7 +1249,13 @@ PHP_HELP_SEPARATOR([Libtool:])
PHP_CONFIGURE_PART(Configuring libtool)
LDFLAGS="$LDFLAGS $PHP_AIX_LDFLAGS"
+
+dnl Only allow AC_PROG_CXX if it's explicitly called (by PHP_REQUIRE_CXX)
+dnl otherwise AC_PROG_LIBTOOL fails if there is no working C++ compiler
+AC_PROVIDE_IFELSE([PHP_REQUIRE_CXX], [AC_PROG_CXX], [undefine([AC_PROG_CXX])
+AC_DEFUN([AC_PROG_CXX], [])])
AC_PROG_LIBTOOL
+
if test "$enable_debug" != "yes"; then
PHP_SET_LIBTOOL_VARIABLE([--silent])
fi