summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSascha Schumann <sas@php.net>1999-11-20 19:00:17 +0000
committerSascha Schumann <sas@php.net>1999-11-20 19:00:17 +0000
commit51c83e9f4b00c6bed2f4656ebcd8dfbe8f1f3f63 (patch)
treef2ad6101d6df8ec67eadc032e5ca58b1fed396bd /configure.in
parente4e8c3539fed94c04aa204f0b5a0880acac9c625 (diff)
downloadphp-git-51c83e9f4b00c6bed2f4656ebcd8dfbe8f1f3f63.tar.gz
--enable-versioning can now be used with CGI/AOLserver as well. Note that
we do not use versioning per se anymore, but export only the required symbols.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 14 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 30cad7e1cc..f9782e9c98 100644
--- a/configure.in
+++ b/configure.in
@@ -372,19 +372,6 @@ abs_builddir=`pwd`
AC_SUBST(abs_srcdir)
AC_SUBST(abs_builddir)
-RESULT=no
-AC_MSG_CHECKING(whether to enable versioning)
-AC_ARG_ENABLE(versioning,
-[ --enable-versioning Take advantage of versioning and scoping.
- See INSTALL for more information],
-[
- if test "$enableval" = "yes" ; then
- EXTRA_LDFLAGS="-export-symbols \$(srcdir)/php.sym"
- RESULT="yes"
- fi
-])
-AC_MSG_RESULT($RESULT)
-
AC_MSG_CHECKING(whether to use a configuration file)
AC_ARG_WITH(config-file-path,
[ --with-config-file-path=PATH
@@ -599,6 +586,20 @@ esyscmd(./scripts/config-stubs ext)
PHP_OUTPUT(sapi/$PHP_SAPI/Makefile)
+RESULT=no
+AC_MSG_CHECKING(whether to enable versioning)
+AC_ARG_ENABLE(versioning,
+[ --enable-versioning Export only required symbols.
+ See INSTALL for more information],
+[
+ test -z "$PHP_SYM_FILE" && PHP_SYM_FILE="$abs_srcdir/sapi/$PHP_SAPI/php.sym"
+ if test "$enableval" = "yes" && test -f "$PHP_SYM_FILE"; then
+ EXTRA_LDFLAGS="-export-symbols $PHP_SYM_FILE"
+ RESULT="yes"
+ fi
+])
+AC_MSG_RESULT($RESULT)
+
divert(4)
enable_shared=yes