summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJani Taskinen <jani@php.net>2007-10-01 12:40:54 +0000
committerJani Taskinen <jani@php.net>2007-10-01 12:40:54 +0000
commit2bc631fb4040b731388fb126c2ca76a06d3989d1 (patch)
treedbfc1e424304b881f3cb6eca8ab7d9d22b75d6b2 /configure.in
parent27e8fa0d31950854c78580264e28008e7f46325d (diff)
downloadphp-git-2bc631fb4040b731388fb126c2ca76a06d3989d1.tar.gz
MFH:- Added common getopt implementation to core.
MFH:- Added long-option feature to getopt(). MFH:- Made getopt() available on win32 systems. MFH: Patch by: David Soria Parra <dsp@php.net> [DOC]: These changes will be available from 5.3+ # Note: Fixed also tests and synced basic_functions.c with HEAD.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 3f641fae1c..d44a06eb80 100644
--- a/configure.in
+++ b/configure.in
@@ -1146,7 +1146,7 @@ esac
if test "$PHP_CLI" != "no"; then
PHP_CLI_TARGET="\$(SAPI_CLI_PATH)"
PHP_INSTALL_CLI_TARGET="install-cli"
- PHP_ADD_SOURCES(sapi/cli, php_cli.c php_cli_readline.c getopt.c,, cli)
+ PHP_ADD_SOURCES(sapi/cli, php_cli.c php_cli_readline.c,, cli)
PHP_INSTALLED_SAPIS="cli $PHP_SAPI"
else
PHP_INSTALLED_SAPIS="$PHP_SAPI"
@@ -1296,7 +1296,7 @@ PHP_INSTALL_HEADERS([Zend/ TSRM/ include/ main/ main/streams/ regex/])
PHP_ADD_SOURCES(TSRM, TSRM.c tsrm_strtok_r.c tsrm_virtual_cwd.c)
-PHP_ADD_SOURCES(main, main.c snprintf.c spprintf.c php_sprintf.c \
+PHP_ADD_SOURCES(main, main.c snprintf.c spprintf.c getopt.c php_sprintf.c \
safe_mode.c fopen_wrappers.c alloca.c php_scandir.c \
php_ini.c SAPI.c rfc1867.c php_content_types.c strlcpy.c \
strlcat.c mergesort.c reentrancy.c php_variables.c php_ticks.c \