summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrei Zmievski <andrei@php.net>1999-12-18 23:25:55 +0000
committerAndrei Zmievski <andrei@php.net>1999-12-18 23:25:55 +0000
commitce10927efb8a37b1405a07ce9741e4259e81e896 (patch)
tree915864aa746f881bfb74ede95bc080501cd43106 /configure.in
parenta1ad2872eebc17448b115a1817e95b63e3ad17e9 (diff)
downloadphp-git-ce10927efb8a37b1405a07ce9741e4259e81e896.tar.gz
Added --without-pear option.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1ebc0050f4..fbfe83eb0a 100644
--- a/configure.in
+++ b/configure.in
@@ -605,6 +605,21 @@ AC_ARG_ENABLE(low-memory,
])
AC_MSG_RESULT($PHP_LOW_MEMORY)
+AC_MSG_CHECKING(whether to install PEAR)
+AC_ARG_WITH(pear,
+[ --without-pear Do not install PEAR],[
+ if test "$withval" = "yes"; then
+ PEAR_DIR=pear
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ fi
+],[
+ PEAR_DIR=pear
+ AC_MSG_RESULT(yes)
+])
+AC_SUBST(PEAR_DIR)
+
PHP_SAPI=cgi
PHP_BUILD_PROGRAM
dnl paths to the targets relative to the build directory