summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSascha Schumann <sas@php.net>2000-07-26 14:53:54 +0000
committerSascha Schumann <sas@php.net>2000-07-26 14:53:54 +0000
commit2c420944941cf6d7261b99af157a186217c6f2c8 (patch)
tree5eb0016e96d5d2658629dc546a0b3598027d3915 /configure.in
parente4b7e9e9166a615f497d10e2ec01cbf67dcba7e2 (diff)
downloadphp-git-2c420944941cf6d7261b99af157a186217c6f2c8.tar.gz
Clean up the mess WRT rebuilding a limited set of files.
Earlier changes were based upon a wrong assumption (that CONFIG_FILES could be relied upon).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 11 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 7bcc7e92ce..e948a70471 100644
--- a/configure.in
+++ b/configure.in
@@ -795,20 +795,16 @@ PHP_CONFIGURE_PART(Generating files)
PHP_GEN_CONFIG_VARS
touch .deps
-#libphp4.module
-AC_OUTPUT([php4.spec Zend/Makefile
- build-defs.h
- $PHP_OUTPUT_FILES
- ], [], [
-
-if test "$CONFIG_FILES" = ""; then
- PHP_GEN_MAKEFILES
-else
- for file in $PHP_FAST_OUTPUT_FILES; do
- if test "\$file" = "\$CONFIG_FILES"; then
- PHP_GEN_MAKEFILE(\$file)
- fi
- done
+ALL_OUTPUT_FILES="php4.spec Zend/Makefile build-defs.h $PHP_OUTPUT_FILES"
+
+AC_OUTPUT($ALL_OUTPUT_FILES, [], [
+
+if test "\$CONFIG_FILES" = "$ALL_OUTPUT_FILES"; then
+ REDO_ALL=yes
+fi
+
+if test -n "\$REDO_ALL"; then
+ PHP_GEN_MAKEFILES($PHP_FAST_OUTPUT_FILES)
fi
if test ! -f $srcdir/ext/bcmath/number.c; then
@@ -834,7 +830,7 @@ cat >Zend/zend_config.h <<FEO
FEO
# run this only when generating all the files?
-if test "\$CONFIG_FILES" = ""; then
+if test -n "\$REDO_ALL"; then
# Hacking while airborne considered harmful.
#
echo "creating main/internal_functions.c"