summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSascha Schumann <sas@php.net>2000-07-09 20:39:18 +0000
committerSascha Schumann <sas@php.net>2000-07-09 20:39:18 +0000
commite51571595c66f1084b514ca8985dd5d47a8c9a08 (patch)
treed73f9e2320aa940acb76a5d171ba614f9b81b0d7 /configure.in
parentc1ed6ef9cc7a35e2cf0e703f6adf51a657fc555b (diff)
downloadphp-git-e51571595c66f1084b514ca8985dd5d47a8c9a08.tar.gz
Add support for building C++ sources.
In your extension's config.m4, you need to use the m4 macro PHP_REQUIRE_CXX This shall be called only, if your extension is enabled. C++ source files shall not be put into the LTLIBRARY_SOURCES macro. Instead, the filename of the object shall be put into LTLIBRARY_OBJECTS_X. I.e. if your extension foo consists of foo.cxx, use LTLIBRARY_OBJECTS_X = foo.lo
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1953c769f3..9d9a5123b5 100644
--- a/configure.in
+++ b/configure.in
@@ -694,6 +694,7 @@ PHP_SUBST(CONFIGURE_COMMAND)
PHP_SUBST(CPP)
PHP_SUBST(CPPFLAGS)
PHP_SUBST(CXX)
+PHP_SUBST(CXXFLAGS)
PHP_SUBST(DEBUG_CFLAGS)
PHP_SUBST(DEFS)
PHP_SUBST(EXTENSION_DIR)
@@ -751,6 +752,7 @@ if test "$enable_debug" != "yes"; then
fi
PHP_COMPILE='$(LIBTOOL) --mode=compile $(COMPILE) -c $<'
+CXX_PHP_COMPILE='$(LIBTOOL) --mode=compile $(CXX_COMPILE) -c $<'
if test "$enable_shared" = "yes"; then
SHARED_LIBTOOL='$(LIBTOOL)'
@@ -761,6 +763,7 @@ else
SHARED_LIBTOOL='$(SHELL) $(top_builddir)/shlibtool'
else
PHP_COMPILE='$(COMPILE) -c $< && touch $@'
+ CXX_PHP_COMPILE='$(CXX_COMPILE) -c $< && touch $@'
fi
fi