summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorfoobar <sniper@php.net>2002-01-09 03:40:51 +0000
committerfoobar <sniper@php.net>2002-01-09 03:40:51 +0000
commitfa41fe864653a1696e5ead5f2e5c3a01b91ba708 (patch)
tree00a34e35e97a027555b2aecb0b3193aaaa8992a1 /configure.in
parentf50277f003ab2c965a678b99ee493bd77c460953 (diff)
downloadphp-git-fa41fe864653a1696e5ead5f2e5c3a01b91ba708.tar.gz
Reverted Hartmut's patch as it caused more trouble than it solved.
# Broke my build totally. The 'correct' fix is to make the checks better # everywhere. ie. to check for existance of the library/symbol in some lib.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 9bb88cf2dc..fa77e0ba99 100644
--- a/configure.in
+++ b/configure.in
@@ -242,7 +242,7 @@ AC_CHECK_LIB(nsl, gethostname, [
fi
-AC_CHECK_LIB(dl, dlopen,[LIBS="-ldl $LIBS"])
+AC_CHECK_LIB(dl, dlopen,[PHP_ADD_LIBRARY(dl)])
dnl The sin may be in a library which need not be specifed
dnl as well as res_search resides in libsocket
@@ -736,7 +736,7 @@ if test "$abs_srcdir" != "$abs_builddir"; then
INCLUDES="$INCLUDES -I\$(top_srcdir)/TSRM"
fi
-EXTRA_LIBS="$EXTRA_LIBS $DLIBS $LIBS $PHP_EXTENSION_LIBS"
+EXTRA_LIBS="$EXTRA_LIBS $DLIBS $LIBS"
unset LIBS LDFLAGS
PHP_CONFIGURE_PART(Configuring TSRM)