summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorfoobar <sniper@php.net>2002-07-23 01:58:02 +0000
committerfoobar <sniper@php.net>2002-07-23 01:58:02 +0000
commit2fcd5025228b6bc21b17cd2cae3fa11c195e7290 (patch)
tree881f9dc58c1b1a31d4f891cc977d4fec57bd6238 /configure.in
parent3177f1ca2a3d8ec838493b5ee1dc4340c7069700 (diff)
downloadphp-git-2fcd5025228b6bc21b17cd2cae3fa11c195e7290.tar.gz
This should fix those solaris+gcc bugs when --enable-libgcc is not used
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in57
1 files changed, 27 insertions, 30 deletions
diff --git a/configure.in b/configure.in
index 89eeb4813e..0febc5dfb1 100644
--- a/configure.in
+++ b/configure.in
@@ -82,36 +82,6 @@ if test -n "$with_apache" && test -n "$with_apxs"; then
fi
-
-dnl Platform-specific compile settings.
-dnl -------------------------------------------------------------------------
-
-dnl if host_alias is empty, ac_cv_host_alias may still have the info
-if test -z "$host_alias"; then
- host_alias=$ac_cv_host_alias
-fi
-
-case $host_alias in
-*solaris*)
- CPPFLAGS="$CPPFLAGS -D_POSIX_PTHREAD_SEMANTICS"
- if test "${enable_libgcc+set}" != "set" && test "$GCC" = "yes"; then
- enable_libgcc=yes
- fi
- ;;
-*dgux*)
- CPPFLAGS="$CPPFLAGS -D_BSD_TIMEOFDAY_FLAVOR";;
-*darwin*|*rhapsody*)
- CPPFLAGS="$CPPFLAGS -no-cpp-precomp"
- php_multiple_shlib_versions_ok=yes;;
-*beos*)
- beos_threads=1
- LIBS="$LIBS -lbe -lroot";;
-*mips*)
- CPPFLAGS="$CPPFLAGS -D_XPG_IV";;
-esac
-
-
-
dnl Settings we want to make before the checks.
dnl -------------------------------------------------------------------------
@@ -185,6 +155,33 @@ if test "$ac_cv_c_const" = "yes" ; then
fi
+dnl Platform-specific compile settings.
+dnl -------------------------------------------------------------------------
+
+dnl if host_alias is empty, ac_cv_host_alias may still have the info
+if test -z "$host_alias"; then
+ host_alias=$ac_cv_host_alias
+fi
+
+case $host_alias in
+*solaris*)
+ CPPFLAGS="$CPPFLAGS -D_POSIX_PTHREAD_SEMANTICS"
+ if test "${enable_libgcc+set}" != "set" && test "$GCC" = "yes"; then
+ enable_libgcc=yes
+ fi
+ ;;
+*dgux*)
+ CPPFLAGS="$CPPFLAGS -D_BSD_TIMEOFDAY_FLAVOR";;
+*darwin*|*rhapsody*)
+ CPPFLAGS="$CPPFLAGS -no-cpp-precomp"
+ php_multiple_shlib_versions_ok=yes;;
+*beos*)
+ beos_threads=1
+ LIBS="$LIBS -lbe -lroot";;
+*mips*)
+ CPPFLAGS="$CPPFLAGS -D_XPG_IV";;
+esac
+
dnl Include Zend and TSRM configurations.
dnl -------------------------------------------------------------------------