summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJon Parise <jon@php.net>2003-08-21 06:24:17 +0000
committerJon Parise <jon@php.net>2003-08-21 06:24:17 +0000
commit34821ed4742f29612c4b1041a92ae08fe8c9fac1 (patch)
treea432524eee9cb4f16d6a15cf464a37da5c20055d /configure.in
parentbf06717b1363abaf4c76deed07f1bee45e588576 (diff)
downloadphp-git-34821ed4742f29612c4b1041a92ae08fe8c9fac1.tar.gz
Under FreeBSD, statfs(2) requires both <sys/mount.h> _and_ <sys/param.h>.
The autoconf check for <sys/mount.h> was failing because <sys/param.h> wasn't being universally included. This gets disk_total_space() and disk_free_space() working again under FreeBSD.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 45e82974c6..d04a272dce 100644
--- a/configure.in
+++ b/configure.in
@@ -327,6 +327,7 @@ PHP_MISSING_FCLOSE_DECL
dnl QNX requires unix.h to allow functions in libunix to work properly
AC_CHECK_HEADERS([ \
ApplicationServices/ApplicationServices.h \
+sys/param.h \
sys/types.h \
sys/time.h \
netinet/in.h \
@@ -372,6 +373,9 @@ sys/utsname.h \
sys/ipc.h \
dlfcn.h
],[],[],[
+#ifdef HAVE_SYS_PARAM_H
+#include <sys/param.h>
+#endif
#ifdef HAVE_SYS_TYPES_H
#include <sys/types.h>
#endif