summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMarcus Boerger <helly@php.net>2003-09-14 09:12:54 +0000
committerMarcus Boerger <helly@php.net>2003-09-14 09:12:54 +0000
commit9b98e42f3590e4b2d70923632b445df32a9dfc5e (patch)
tree2001a0f0cf2545722de983b2d5dab7de5b0b61de /configure.in
parentcb5b1690ace07cf4af15b04c2a09b80f376fc976 (diff)
downloadphp-git-9b98e42f3590e4b2d70923632b445df32a9dfc5e.tar.gz
- Add length modifiers(ll, j, t, h, hh)
# Still missing formats (%a, %A) # Still missing modifier (l) in (%lc, %ls) # Still missing modifier (L) in (%La, %LA, %Le, %LE, %Lf, %LF, %Lg, %LG) # C99 requires any conversion to be able to produce at least 4095 # characters. Implementation only allows less then 512. # # Only inside ext/mbstring etc. we could use %lc and %ls. And none of the # rest should affect us until we stay with double and avoid long double.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 68b97badf1..101e650a88 100644
--- a/configure.in
+++ b/configure.in
@@ -401,6 +401,12 @@ PHP_TM_GMTOFF
PHP_STRUCT_FLOCK
PHP_SOCKLEN_T
+AC_CHECK_SIZEOF(intmax_t, 0)
+AC_CHECK_SIZEOF(size_t, 8)
+AC_CHECK_SIZEOF(ssize_t, 8)
+AC_CHECK_SIZEOF(ptrdiff_t, 8)
+AC_CHECK_SIZEOF(long long, 8)
+AC_CHECK_SIZEOF(long long int, 8)
AC_CHECK_SIZEOF(long, 8)
AC_CHECK_SIZEOF(int, 4)
@@ -1166,7 +1172,8 @@ PHP_ADD_SOURCES(Zend, \
zend_ini.c zend_qsort.c zend_multibyte.c zend_ts_hash.c zend_stream.c)
if test -r "$abs_srcdir/Zend/zend_objects.c"; then
- PHP_ADD_SOURCES(Zend, zend_objects.c zend_object_handlers.c zend_objects_API.c zend_mm.c zend_default_classes.c zend_reflection_api.c)
+ PHP_ADD_SOURCES(Zend, zend_objects.c zend_object_handlers.c zend_objects_API.c zend_mm.c \
+ zend_default_classes.c zend_reflection_api.c zend_interfaces.c)
fi
dnl Selectively disable optimization due to high RAM usage during