summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSascha Schumann <sas@php.net>1999-12-19 13:59:29 +0000
committerSascha Schumann <sas@php.net>1999-12-19 13:59:29 +0000
commit48fb8ba3cd18e9b81d0992531621fa9aed0d2a27 (patch)
treeb337f9bb3eeb9ad4fe1df4d5cbbe94c4305bb26a /configure.in
parent213d0e2fb260788de33dc7f7eca8d50550255c68 (diff)
downloadphp-git-48fb8ba3cd18e9b81d0992531621fa9aed0d2a27.tar.gz
Refine PEAR option. Since it does not reference anything external, it should be
AC_ARG_ENABLE instead of AC_ARG_WITH.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 12 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index fbfe83eb0a..22ffe72b3c 100644
--- a/configure.in
+++ b/configure.in
@@ -605,19 +605,20 @@ AC_ARG_ENABLE(low-memory,
])
AC_MSG_RESULT($PHP_LOW_MEMORY)
-AC_MSG_CHECKING(whether to install PEAR)
-AC_ARG_WITH(pear,
-[ --without-pear Do not install PEAR],[
- if test "$withval" = "yes"; then
- PEAR_DIR=pear
- AC_MSG_RESULT(yes)
- else
- AC_MSG_RESULT(no)
- fi
+AC_ARG_ENABLE(pear,
+[ --disable-pear Do not install PEAR],[
+ PHP_PEAR=$enableval
],[
- PEAR_DIR=pear
- AC_MSG_RESULT(yes)
+ PHP_PEAR=yes
])
+
+AC_MSG_CHECKING(whether to install PEAR)
+AC_MSG_RESULT($PHP_PEAR)
+
+if test "$PHP_PEAR" = "yes"; then
+ PEAR_DIR=pear
+fi
+
AC_SUBST(PEAR_DIR)
PHP_SAPI=cgi