summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStig Bakken <ssb@php.net>2000-07-18 11:02:28 +0000
committerStig Bakken <ssb@php.net>2000-07-18 11:02:28 +0000
commit7bb67a620032ed679826b103e33282ea2126be70 (patch)
treeb4b9812fd2e0bf37d156650654b75b2ebf52b799 /configure.in
parentbb5987fe7410b2172bc2b96000432899fe1387aa (diff)
downloadphp-git-7bb67a620032ed679826b103e33282ea2126be70.tar.gz
@Set default include_path so PEAR files can be reached (Stig)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c3dcf12f1f..d10f4cb510 100644
--- a/configure.in
+++ b/configure.in
@@ -665,6 +665,9 @@ ZEND_MODULE_API_NO=`egrep '#define ZEND_MODULE_API_NO ' $srcdir/Zend/modules.h|s
EXTENSION_DIR="$prefix/lib/php/extensions/$PART1-$PART2-$ZEND_MODULE_API_NO"
+PEAR_INSTALLDIR="$prefix/lib/php"
+INCLUDE_PATH=".:$PEAR_INSTALLDIR"
+
AC_BUILD_RPATH
EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PHP_LDFLAGS"
@@ -702,6 +705,7 @@ PHP_SUBST(EXTENSION_DIR)
PHP_SUBST(EXTRA_LDFLAGS)
PHP_SUBST(EXTRA_LIBS)
PHP_SUBST(INCLUDES)
+PHP_SUBST(INCLUDE_PATH)
PHP_SUBST(INSTALL_IT)
PHP_SUBST(LEX)
PHP_SUBST(LEX_OUTPUT_ROOT)
@@ -710,6 +714,7 @@ PHP_SUBST(LIBTOOL)
PHP_SUBST(LN_S)
PHP_SUBST(NATIVE_RPATHS)
PHP_SUBST(PEAR_DIR)
+PHP_SUBST(PEAR_INSTALLDIR)
PHP_SUBST(PHP_BUILD_DATE)
PHP_SUBST(PHP_COMPILE)
PHP_SUBST(PHP_LDFLAGS)