summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStig Bakken <ssb@php.net>2000-07-24 23:55:34 +0000
committerStig Bakken <ssb@php.net>2000-07-24 23:55:34 +0000
commitfbc947f43fc57ecfd35ec058bf3a9cee597d4353 (patch)
tree068b4c9d5c1a9ff7c168733a5a1eb857d327a81b /configure.in
parent576b6e923679d1bbf5dc8098bc3b178f78f58166 (diff)
downloadphp-git-fbc947f43fc57ecfd35ec058bf3a9cee597d4353.tar.gz
* generate pear scripts properly with configure
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 15 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index d10f4cb510..75d6bf38f6 100644
--- a/configure.in
+++ b/configure.in
@@ -542,7 +542,6 @@ if test "$PHP_DMALLOC" = "yes"; then
CPPFLAGS="$CPPFLAGS -DDMALLOC_FUNC_CHECK"
fi
-
PHP_ARG_ENABLE(pear,whether to install PEAR,
[ --disable-pear Do not install PEAR],yes)
@@ -550,8 +549,11 @@ if test "$PHP_PEAR" = "yes"; then
PEAR_DIR=pear
fi
-
-
+PHP_OUTPUT(pear/pear)
+PHP_OUTPUT(pear/run-tests)
+PHP_OUTPUT(pear/phpize)
+PHP_OUTPUT(pear/php-config)
+PHP_OUTPUT(pear/PEAR.php)
divert(5)
@@ -666,6 +668,7 @@ ZEND_MODULE_API_NO=`egrep '#define ZEND_MODULE_API_NO ' $srcdir/Zend/modules.h|s
EXTENSION_DIR="$prefix/lib/php/extensions/$PART1-$PART2-$ZEND_MODULE_API_NO"
PEAR_INSTALLDIR="$prefix/lib/php"
+
INCLUDE_PATH=".:$PEAR_INSTALLDIR"
AC_BUILD_RPATH
@@ -798,7 +801,15 @@ AC_OUTPUT([php4.spec Zend/Makefile
$PHP_OUTPUT_FILES
], [], [
-PHP_GEN_MAKEFILES
+if test "$CONFIG_FILES" = ""; then
+ PHP_GEN_MAKEFILES
+else
+ for file in $PHP_FAST_OUTPUT_FILES; do
+ if test "$file" = "$CONFIG_FILES"; then
+ PHP_GEN_MAKEFILE($file)
+ fi
+ done
+fi
if test ! -f $srcdir/ext/bcmath/number.c; then
echo "creating number.c"