summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorChristopher Jones <sixd@php.net>2012-03-02 00:07:41 +0000
committerChristopher Jones <sixd@php.net>2012-03-02 00:07:41 +0000
commit949ef40139a008c9bbf387a677018f3a85fbf75a (patch)
treef150c22668013e2daf5b583b5c0679571e4c5e2b /configure.in
parent4fff4753ac8c128685e58c5d002de08b3af801ec (diff)
downloadphp-git-949ef40139a008c9bbf387a677018f3a85fbf75a.tar.gz
Fixed bug #61172 (Add Apache 2.4 support)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7ed2d93912..8f579eff61 100644
--- a/configure.in
+++ b/configure.in
@@ -1550,6 +1550,21 @@ cat <<X
X
fi
+ if test "$PHP_SAPI" = "apache2handler" || test "$PHP_SAPI" = "apache2filter"; then
+ if test "$APACHE_VERSION" -ge 2004001; then
+ if test -z "$APACHE_THREADED_MPM"; then
+cat <<X
++--------------------------------------------------------------------+
+| *** WARNING *** |
+| |
+| You have built PHP for Apache's current non-threaded MPM. |
+| If you change Apache to use a threaded MPM you must reconfigure |
+| PHP with --enable-maintainer-zts |
+X
+ fi
+ fi
+ fi
+
# Warn about linking Apache with libpthread if oci8 extension is enabled on linux.
if test "$PHP_OCI8" != "no"; then
if test "$PHP_SAPI" = "apache"; then