summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDmitry Stogov <dmitry@zend.com>2015-05-26 17:33:25 +0300
committerDmitry Stogov <dmitry@zend.com>2015-05-26 17:33:25 +0300
commit7dac4d449f72d7eb029aa1a8ee87aaf38e17e1c5 (patch)
tree45b76f66d89dbf19d268e8a640877451b822e91b /configure.in
parentca31711625095c2d6e308d7f0fc9d371ad0934d4 (diff)
downloadphp-git-7dac4d449f72d7eb029aa1a8ee87aaf38e17e1c5.tar.gz
Add targets to simplify building PHP with FDO (Feedback Directed Optimisation)
PHP should be built with the folowing steps: make clean make -j4 prof-gen ; now php should be trained with some scripts ; for example `sapi/cgi/php -T 1000 /var/www/http/wordpress/index.php > /dev/null` make prof-clean make -j4 prof-use The "properly" trained build may give up to 10% real performance boost! "Improprly" trained PHP might be even slower.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ffc714ff5f..9aefa2b964 100644
--- a/configure.in
+++ b/configure.in
@@ -1435,10 +1435,10 @@ CC=$old_CC
PHP_CONFIGURE_PART(Generating files)
CXXFLAGS_CLEAN=$CXXFLAGS
-CFLAGS_CLEAN=$CFLAGS
+CFLAGS_CLEAN="$CFLAGS \$(PROF_FLAGS)"
CFLAGS="\$(CFLAGS_CLEAN) $standard_libtool_flag"
INLINE_CFLAGS="$INLINE_CFLAGS $standard_libtool_flag"
-CXXFLAGS="$CXXFLAGS $standard_libtool_flag"
+CXXFLAGS="$CXXFLAGS $standard_libtool_flag \$(PROF_FLAGS)"
if test "$PHP_PHAR" != "no" && test "$PHP_CLI" != "no"; then
pharcmd=pharcmd