summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 77e1bad5e3..80fe2a7a07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,9 @@ PHP_CANONICAL_HOST_TARGET
AC_CONFIG_HEADER(main/php_config.h)
AH_TOP([
+#ifndef PHP_CONFIG_H
+#define PHP_CONFIG_H
+
#if defined(__GNUC__) && __GNUC__ >= 4
# define ZEND_API __attribute__ ((visibility("default")))
# define ZEND_DLEXPORT __attribute__ ((visibility("default")))
@@ -98,6 +101,8 @@ int zend_sprintf(char *buffer, const char *format, ...);
#endif /* ifndef ZEND_ACCONFIG_H_NO_C_PROTOS */
#undef PTHREADS
+
+#endif /* PHP_CONFIG_H */
])
PHP_MAJOR_VERSION=7