summaryrefslogtreecommitdiff
path: root/ext/pgsql/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/pgsql/Makefile.am')
-rw-r--r--ext/pgsql/Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/ext/pgsql/Makefile.am b/ext/pgsql/Makefile.am
index fa41b29721..5a4a3e8605 100644
--- a/ext/pgsql/Makefile.am
+++ b/ext/pgsql/Makefile.am
@@ -1,6 +1,16 @@
# $Id$
-INCLUDES=@INCLUDES@ -I@top_srcdir@ -I@top_srcdir@/libzend
-noinst_LIBRARIES=libphpext_pgsql.a
-libphpext_pgsql_a_SOURCES=pgsql.c
+phplibdir=$(libdir)/php
+
+SRC=pgsql.c
+INCLUDES=@INCLUDES@ @PGSQL_INCLUDE@ -I@top_srcdir@ -I@top_srcdir@/libzend
+noinst_LIBRARIES=@PGSQL_STATIC@
+EXTRA_LIBRARIES=libphpext_pgsql.a
+libphpext_pgsql_a_SOURCES=$(SRC)
+phplib_LTLIBRARIES=@PGSQL_SHARED@
+EXTRA_LTLIBRARIES=pgsql.la
+pgsql_la_SOURCES=$(SRC)
+pgsql_la_LIBADD=@PGSQL_LFLAGS@ @PGSQL_LIBS@
+pgsql_la_LDFLAGS=-avoid-version -module -rpath $(phplibdir)
+EXTRA_LIBS=