summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Laager <rlaager@pidgin.im>2006-02-08 07:44:23 +0000
committerRichard Laager <rlaager@pidgin.im>2006-02-08 07:44:23 +0000
commitf209fe069eb7d8d54c5faa1427cbefda36563100 (patch)
tree86b026eaeffbbae169c42cff16cf59bd6467d453 /Makefile.am
parentd095a1583c90c93e8e748098152f8e26e7c7f299 (diff)
downloadpidgin-f209fe069eb7d8d54c5faa1427cbefda36563100.tar.gz
[gaim-migrate @ 15542]
SF Patch #1265514 This patch adds intltool integration. It works here; let me know if it breaks anything for you.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 998577a0a0..d434ff973a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,9 +4,12 @@ EXTRA_DIST = \
gaim.pc.in \
gaim.spec.in \
gaim.apspec.in \
- gaim.desktop \
+ gaim.desktop.in \
gaim-installer.nsi \
HACKING \
+ intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in \
PROGRAMMING_NOTES \
setup-gettext \
ChangeLog.win32 \
@@ -36,9 +39,11 @@ distcheck-hook: plugins/perl/common/Gaim.pm
# cp plugins/perl/common/Gaim.pm $(distdir)/plugins/perl/common
appsdir = $(datadir)/applications
-apps_DATA = gaim.desktop
+apps_in_files = gaim.desktop.in
+apps_DATA = $(apps_in_files:.desktop.in=.desktop)
+@INTLTOOL_DESKTOP_RULE@
-SUBDIRS = doc intl m4macros pixmaps plugins po sounds src
+SUBDIRS = doc m4macros pixmaps plugins po sounds src
docs: Doxyfile
if HAVE_DOXYGEN