summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorElliott Sales de Andrade <qulogic@pidgin.im>2010-03-10 05:10:43 +0000
committerElliott Sales de Andrade <qulogic@pidgin.im>2010-03-10 05:10:43 +0000
commit0b993e496cb50223f600579e9718839f4cd1da34 (patch)
tree4a43c22ce3cf196f35b6c41e625c08e383cd3c12 /configure.ac
parent368b225e40de3801e08466a8b8dbfcb6ba074bbc (diff)
downloadpidgin-0b993e496cb50223f600579e9718839f4cd1da34.tar.gz
Don't use old versions of libgadu if the user specified a location for the
headers/libraries. GG_DEFAULT_PROTOCOL_VERSION seemed the best bet since GG_LIBGADU_VERSION is a string, but maybe someone can find something that's better. Refs #10542.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 22 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0df5c1e1b0..65e4d8b770 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1049,9 +1049,28 @@ if test "x$gadu_libs" = "xyes"; then
#error "libgadu is not compatible with the GPL when compiled with OpenSSL support."
#endif
]])], [
- AC_MSG_RESULT(yes)
- AC_DEFINE([HAVE_LIBGADU], [1],
- [Define to 1 if you have libgadu.])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <libgadu.h>]], [[
+#if GG_DEFAULT_PROTOCOL_VERSION < 0x2e
+#error "Your libgadu version is too old. libpurple requires 1.9.0-rc2 or higher."
+#endif
+ ]])], [
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([HAVE_LIBGADU], [1],
+ [Define to 1 if you have libgadu.])
+ ], [
+ AC_MSG_RESULT(no)
+ echo
+ echo
+ echo "Your supplied copy of libgadu is too old."
+ echo "Install version 1.9.0-rc2 or newer."
+ echo "Then rerun this ./configure"
+ echo
+ echo "Falling back to using our own copy of libgadu"
+ echo
+ GADU_LIBS=""
+ GADU_CFLAGS=""
+ gadu_libs=no
+ ])
], [
AC_MSG_RESULT(no)
echo