summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorElliott Sales de Andrade <qulogic@pidgin.im>2011-11-20 08:57:53 +0000
committerElliott Sales de Andrade <qulogic@pidgin.im>2011-11-20 08:57:53 +0000
commitafc293e1c31d19d57bb6e04eeeb46797b0a18c21 (patch)
treebd24650c1c504e0a8a1bd3448a862ce0a615cd57 /configure.ac
parent737de985ab2a03cc41264a2f202ec5ab53c9c355 (diff)
downloadpidgin-afc293e1c31d19d57bb6e04eeeb46797b0a18c21.tar.gz
Fix signal handling. On this side, it's a slot, not a signal.
And for QObjects that implement signals/slots, we need to also run moc over the source.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b915162916..56ba0e3d57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1399,6 +1399,11 @@ Use --disable-kwallet if you do not need KWallet support.
])
])
+ AC_MSG_CHECKING([for metaobject compiler])
+ MOC=`$PKG_CONFIG --variable=moc_location QtCore`
+ AC_SUBST(MOC)
+ AC_MSG_RESULT([$MOC])
+
dnl Check for kwallet.h; if we don't have it, oh well
if test "$ac_kwallet_includes" != "no"; then
KWALLET_CXXFLAGS="-I$ac_kwallet_includes"