summaryrefslogtreecommitdiff
path: root/libpurple/Makefile.am
diff options
context:
space:
mode:
authorSadrul Habib Chowdhury <sadrul@pidgin.im>2008-03-22 04:45:46 +0000
committerSadrul Habib Chowdhury <sadrul@pidgin.im>2008-03-22 04:45:46 +0000
commit5e452c04c3afbeb4bc4232b4977ce59c4fad2ed7 (patch)
tree569eb66d12e3c7e6f0e54ce413c1b6a0bec35ecc /libpurple/Makefile.am
parent87914b30089be8b48bd7db805a6321124031a7b1 (diff)
downloadpidgin-5e452c04c3afbeb4bc4232b4977ce59c4fad2ed7.tar.gz
Patch from Marcus Lundblad ('mlundblad') to improve audio support in xmpp.
It's now possible to initiate an audio session, sometimes. It's somewhat buggy. Some other issues also need to be resolved: * Properly get rid of the compile warnings * Rename the serv_ functions with proper namespacing. * Possibly rename the purple_media_ functions that don't deal with a PurpleMedia (e.g. purple_media_audio_init_src) to something different, e.g. purple_media_util_, or even purple_gst_util etc. References #34.
Diffstat (limited to 'libpurple/Makefile.am')
-rw-r--r--libpurple/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/libpurple/Makefile.am b/libpurple/Makefile.am
index 745ba414bd..e1a0c0cece 100644
--- a/libpurple/Makefile.am
+++ b/libpurple/Makefile.am
@@ -251,6 +251,8 @@ libpurple_la_LIBADD = \
$(LIBNM_LIBS) \
$(INTLLIBS) \
$(FARSIGHT_LIBS) \
+ $(GSTREAMER_LIBS) \
+ $(GSTPROPS_LIBS) \
-lm
AM_CPPFLAGS = \
@@ -264,4 +266,6 @@ AM_CPPFLAGS = \
$(DBUS_CFLAGS) \
$(LIBXML_CFLAGS) \
$(FARSIGHT_CFLAGS) \
+ $(GSTREAMER_CFLAGS) \
+ $(GSTPROPS_CFLAGS) \
$(LIBNM_CFLAGS)