summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarcus Smith <qwcode@gmail.com>2013-01-18 13:25:15 -0800
committerMarcus Smith <qwcode@gmail.com>2013-01-18 13:25:15 -0800
commitab9ea197bd66b98771d6ba16baf9677044222ded (patch)
treecb1876f1bc18b33f5614a8440101066f744b1807 /setup.py
parent44ec2f95c4030164d4865c2c42e4463b31919e89 (diff)
downloadpip-ab9ea197bd66b98771d6ba16baf9677044222ded.tar.gz
improved docs and cli help
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 8 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index 4ccc1025b..cfeaccbbb 100644
--- a/setup.py
+++ b/setup.py
@@ -2,12 +2,13 @@ import codecs
import os
import re
import sys
+import textwrap
from setuptools import setup
+here = os.path.abspath(os.path.dirname(__file__))
def read(*parts):
- return codecs.open(os.path.join(os.path.abspath(os.path.dirname(__file__)), *parts), 'r').read()
-
+ return codecs.open(os.path.join(here, *parts), 'r', 'utf8').read()
def find_version(*file_paths):
version_file = read(*file_paths)
@@ -17,24 +18,16 @@ def find_version(*file_paths):
return version_match.group(1)
raise RuntimeError("Unable to find version string.")
-long_description = """
-
-The main website for pip is `www.pip-installer.org
-<http://www.pip-installer.org>`_. You can also install
-the `in-development version <https://github.com/pypa/pip/tarball/develop#egg=pip-dev>`_
-of pip with ``easy_install pip==dev``.
-
-"""
-# remove the toctree from sphinx index, as it breaks long_description
-parts = read("docs", "index.txt").split("split here", 2)
-long_description = (parts[0] + long_description + parts[2] +
- "\n\n" + read("docs", "news.txt"))
+long_description = "\n" + "\n".join([
+ read('PROJECT.txt'),
+ read('docs', 'quickstart.txt'),
+ read('CHANGES.txt')])
tests_require = ['nose', 'virtualenv>=1.7', 'scripttest>=1.1.1', 'mock']
setup(name="pip",
version=find_version('pip', '__init__.py'),
- description="pip installs packages. Python packages. An easy_install replacement",
+ description="A tool for installing and managing Python packages.",
long_description=long_description,
classifiers=[
'Development Status :: 5 - Production/Stable',