summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJannis Leidel <jannis@leidel.info>2013-07-23 19:53:54 +0200
committerJannis Leidel <jannis@leidel.info>2013-07-23 19:53:54 +0200
commite3bf9c40ec9061e8e13a17379c950cddea6c29e5 (patch)
tree8d9b0d4fcefc2f9586306e210231fa1ff429e336 /setup.py
parent610bd8582b38fc3ddfd0d1a583943cd7bbf6eae3 (diff)
downloadpip-e3bf9c40ec9061e8e13a17379c950cddea6c29e5.tar.gz
Remove the changelog from the PyPI page and add links to it and the installation docs.
Also some minor stylistic changes.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py40
1 files changed, 19 insertions, 21 deletions
diff --git a/setup.py b/setup.py
index 6538052cb..134700409 100644
--- a/setup.py
+++ b/setup.py
@@ -2,16 +2,17 @@ import codecs
import os
import re
import sys
-import textwrap
from setuptools import setup, find_packages
here = os.path.abspath(os.path.dirname(__file__))
+
def read(*parts):
# intentionally *not* adding an encoding option to open
# see here: https://github.com/pypa/virtualenv/issues/201#issuecomment-3145690
return codecs.open(os.path.join(here, *parts), 'r').read()
+
def find_version(*file_paths):
version_file = read(*file_paths)
version_match = re.search(r"^__version__ = ['\"]([^'\"]*)['\"]",
@@ -20,10 +21,8 @@ def find_version(*file_paths):
return version_match.group(1)
raise RuntimeError("Unable to find version string.")
-long_description = "\n" + "\n".join([
- read('PROJECT.txt'),
- read('docs', 'quickstart.rst'),
- read('CHANGES.txt')])
+long_description = "\n" + "\n".join([read('PROJECT.txt'),
+ read('docs', 'quickstart.rst')])
tests_require = ['nose>=1.3.0', 'virtualenv>=1.10', 'scripttest>=1.1.1', 'mock']
@@ -32,18 +31,18 @@ setup(name="pip",
description="A tool for installing and managing Python packages.",
long_description=long_description,
classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Topic :: Software Development :: Build Tools',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.5',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.1',
- 'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Topic :: Software Development :: Build Tools',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.1',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
],
keywords='easy_install distutils setuptools egg virtualenv',
author='The pip developers',
@@ -56,7 +55,6 @@ setup(name="pip",
test_suite='nose.collector',
tests_require=tests_require,
zip_safe=False,
- extras_require = {
- 'testing':tests_require,
- },
- )
+ extras_require={
+ 'testing': tests_require,
+ })