summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index b7d0e8f51..b3aaa3613 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,6 @@
# The following comment should be removed at some point in the future.
# mypy: disallow-untyped-defs=False
-import codecs
import os
import sys
@@ -12,7 +11,7 @@ def read(rel_path):
here = os.path.abspath(os.path.dirname(__file__))
# intentionally *not* adding an encoding option to open, See:
# https://github.com/pypa/virtualenv/issues/201#issuecomment-3145690
- with codecs.open(os.path.join(here, rel_path), 'r') as fp:
+ with open(os.path.join(here, rel_path), 'r') as fp:
return fp.read()