summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBruce Momjian <bruce@momjian.us>2004-12-02 15:32:54 +0000
committerBruce Momjian <bruce@momjian.us>2004-12-02 15:32:54 +0000
commit8408f65252c23040e766b6a3ecde7bff390e2847 (patch)
tree4db202b3d10eab659e3d8c9805691523c9a5555e /configure.in
parente02ef267fc3d41cbba41b2bf404d18a936d28691 (diff)
downloadpostgresql-8408f65252c23040e766b6a3ecde7bff390e2847.tar.gz
Rework libpq threaded SIGPIPE handling to avoid interference with
calling applications. This is done by blocking sigpipe in the libpq thread and using sigpending/sigwait to possibily discard any sigpipe we generated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ed65d5fec1..cbb2279ffe 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-dnl $PostgreSQL: pgsql/configure.in,v 1.387 2004/11/30 06:13:04 tgl Exp $
+dnl $PostgreSQL: pgsql/configure.in,v 1.388 2004/12/02 15:32:50 momjian Exp $
dnl
dnl Developers, please strive to achieve this order:
dnl
@@ -1174,6 +1174,13 @@ AC_CHECK_TYPES(sig_atomic_t, [], [], [#include <signal.h>])
PGAC_FUNC_POSIX_SIGNALS
+if test "$pgac_cv_func_posix_signals" != yes -a "$enable_thread_safety" = yes; then
+ AC_MSG_ERROR([
+*** Thread-safety requires POSIX signals, which are not supported by your
+*** operating system.
+])
+fi
+
if test $ac_cv_func_fseeko = yes; then
AC_SYS_LARGEFILE
fi