summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
...
* Comment out entries for IPv6 localhost connections, since they failTom Lane2003-08-011-4/+5
| | | | on machines with no IPv6 support.
* Postmaster erroneously rejected SSL connections on IPv6.Tom Lane2003-08-011-2/+2
|
* Fix some unprotected references to AF_UNIX ... wouldn't compile onTom Lane2003-08-011-5/+11
| | | | platforms without AF_UNIX sockets.
* inet_recv() wasn't IPv6-ready.Tom Lane2003-08-011-13/+10
|
* Update, add Greg:Bruce Momjian2003-08-011-4/+5
| | | | | | | | < * Fernando Nasser <fnasser@redhat.com> of Red Hat < * Gavin Sherry <swm@linuxworld.com.au> of Alcove Systems Engineering > * Fernando is Fernando Nasser <fnasser@redhat.com> of Red Hat > * Gavin is Gavin Sherry <swm@linuxworld.com.au> of Alcove Systems Engineering > * Greg is Greg Sabino Mullane <greg@turnstep.com>
* Add:Bruce Momjian2003-08-011-3/+3
| | | | | < > o Allow PL/pgSQL EXECUTE query_var INTO record_var;
* Code review for sslmode patch: eliminate memory leak, avoid giving aTom Lane2003-08-012-100/+42
| | | | | | completely useless error message in 'allow' case, don't retry connection at the sendauth stage (by then the server will either let us in or not, no point in wasting cycles on another try in the other SSL state).
* Since HPUX now exists for Itanium, we should decouple the assumptionTom Lane2003-08-016-17/+37
| | | | | | | | that OS=hpux is the same as CPU=hppa. First steps at doing this. With these patches, we still work on hppa with either gcc or HP's cc. We might work on hpux/itanium with gcc, but I can't test it. Definitely will not work on hpux/itanium with non-gcc compiler, for lack of spinlock code.
* Get the include ordering right for TCL includes vs whatever is comingTom Lane2003-08-011-2/+2
| | | | from --with-includes.
* Missed two places to replace union member.Michael Meskes2003-08-012-3/+3
|
* Fix a few of the more blatantly unportable constructs in this file.Tom Lane2003-08-011-23/+27
|
* Fix inconsistent static-vs-not-static declarations.Tom Lane2003-08-014-10/+7
|
* Fix compile warning.Tom Lane2003-08-012-2/+4
|
* Russian translation updates by Serguei MokhovPeter Eisentraut2003-08-016-1373/+2155
|
* Use only two-part shared library version numbers, for better portabilityPeter Eisentraut2003-08-013-6/+6
| | | | and consistency.
* While having a parallel-make-safe genbki.sh is good, it's better not toPeter Eisentraut2003-08-011-2/+5
| | | | uselessly invoke it in parallel in the first place.
* Make ecpg SQLSTATE-aware. Map existing SQLCODE assignments to SQLSTATEs,Peter Eisentraut2003-08-0115-435/+1129
| | | | | rather than parsing the message. Add some documentation about embedded SQL.
* Update comments.Bruce Momjian2003-08-011-1/+3
|
* Update comments.Bruce Momjian2003-08-011-1/+2
|
* Added missing TO keyword.Michael Meskes2003-08-011-1/+2
|
* - Added some Informix error codes in Informix mode.Michael Meskes2003-08-0120-232/+934
| | | | - Added just another pgtypeslib function.
* cvs log used -b for head, not -rHEAD.Bruce Momjian2003-08-011-2/+2
|
* python needs to be removed from hereMarc G. Fournier2003-08-011-2/+2
|
* clean python out of MakefileMarc G. Fournier2003-08-011-6/+2
|
* remove python module, as its moved to http://www.pygresql.orgMarc G. Fournier2003-08-0114-5581/+0
|
* Fix for Alpha portability.Tom Lane2003-08-011-5/+5
|
* --enable-thread-safeness -> --enable-thread-safetyBruce Momjian2003-08-015-21/+21
|
* Update contrib regression tests for recent error message editing.Tom Lane2003-08-018-22/+22
|
* Add missing #include.Tom Lane2003-08-011-0/+1
|
* Fix some minor portability issues, per Chris K-L.Tom Lane2003-08-012-12/+12
|
* Fix my own mistake in GUC variable annotation.Tom Lane2003-08-011-4/+4
|
* Improve description of restoring pg_dumpall backups, per gripe fromTom Lane2003-08-011-8/+13
| | | | Havard Eidnes.
* Adjust 'permission denied' messages to be more useful and consistent.Tom Lane2003-08-0138-243/+377
|
* Very minor editing.Tom Lane2003-07-311-3/+4
|
* Fix mistaken error code assignments, per Peter's note 7/28/03.Tom Lane2003-07-311-3/+3
|
* When using a temp installation, unset PGUSER and other variables weTom Lane2003-07-311-1/+5
| | | | | | might have inherited from the environment that would possibly cause psql to fail to connect to the temp installation properly. Per trouble report from Markus Bertheau 7/1/03.
* Cause library-preload feature to report error if specified initializationTom Lane2003-07-318-57/+176
| | | | | function is not found. Also, make all the PL libraries have initialization functions with standard names. Patch from Joe Conway.
* Upgrade parsing code for ACLs to be less hokey and more cognizant ofTom Lane2003-07-311-36/+151
| | | | | the actual logical structure and quoting rules being used. Fixes bug reported by Chris K-L on 7/8/03.
* Modify:Bruce Momjian2003-07-311-3/+3
| | | | > * Implement dirty reads or shared row locks and use them in RI triggers
* Modify:Bruce Momjian2003-07-311-3/+3
| | | | > * Implement dirty reads or shared locks and use them in RI triggers
* contraints -> constraintsBruce Momjian2003-07-312-3/+3
| | | | Rod Taylor
* Update Turkish FAQ, Devrim GUNDUZBruce Momjian2003-07-312-1955/+2320
|
* Add fflush of stdout when outputing query.Bruce Momjian2003-07-312-4/+7
|
* dbf2pg - Insert xBase-style .dbf-files into a PostgreSQL-tableBruce Momjian2003-07-313-11/+23
| | | | | | | | | | | | | | | | | | | | | | | | There is an option "-s oldname=newname", which changes the old field name of the dbf-file to the newname in PostgeSQL. If the length of the new name is 0, the field is skiped. If you want to skip the first field of the dbf-file, you get the wildest error-messages from the backend. dbf2pg load the dbf-file via "COPY tablename FROM STDIN". If you skip the first field, it is an \t to much in STDIN. A fix could be an counter j=0, which increments only, if a field is imported (IF (strlen(fields[h].db_name)> 0) j++. And only if j > 1 (if an other field is imported) the \t is printed. An other small bug in the README: -s start Specify the first record-number in the xBase-file we will insert. should be -e start Specify the first record-number in the xBase-file we will insert. Thomas Behr
* Add pretty-printing variants of pg_get_viewdef and related functions.Tom Lane2003-07-305-193/+951
| | | | Patch from Andreas Pflug.
* Add:;Bruce Momjian2003-07-301-2/+3
| | | | > * Allow server log information to be output as INSERT statements
* Fix numeric_smaller, numeric_larger, float4smaller, float4larger,Tom Lane2003-07-302-57/+31
| | | | | | | | float8smaller, float8larger (and thereby the MIN/MAX aggregates on these datatypes) to agree with the datatypes' comparison operations as regards NaN handling. In all these datatypes, NaN is arbitrarily considered larger than any normal value ... but MIN/MAX had not gotten the word. Per recent discussion on pgsql-sql.
* Modify:Bruce Momjian2003-07-301-3/+3
| | | | > * Allow log lines to include session-level information, like database and user
* Cause ARRAY[] construct to return a NULL array, rather than raising anTom Lane2003-07-301-7/+13
| | | | | | error, if any input element is NULL. This is not what we ultimately want, but until arrays can have NULL elements, it will have to do. Patch from Joe Conway.
* Add:Bruce Momjian2003-07-301-2/+3
| | | | > * Add database name and user name to logging options