summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Warner <james.warner@comcast.net>2013-05-05 00:00:00 -0500
committerCraig Small <csmall@enc.com.au>2013-05-11 08:23:52 +1000
commit25201bc9fea611b22674f8a2460f4858281352bc (patch)
treed7de2be4d3b9bc253300529da487cf881a4c7981 /configure.ac
parentdbe27d3ad1d563277f4c6086d85764cfe47fe8f4 (diff)
downloadprocps-ng-25201bc9fea611b22674f8a2460f4858281352bc.tar.gz
build-sys: allow a build when libdl.so is truly absent
The earlier commit purporting to allow top to be built in the absence of that dynamic linking library stopped just a little short of the truth. So this will fix it. Reference(s): commit 5686877cd4c83a2daf1be6f2f7f93cd2c1451e75 Signed-off-by: Jim Warner <james.warner@comcast.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dcc351c..19a8f26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -195,6 +195,7 @@ if test "x$enable_sigwinch" = xyes; then
AC_DEFINE(SIGNALS_LESS, 1, [reduce impact of x-windows resize operations on top])
fi
+DL_LIB=
AC_ARG_ENABLE([numa],
AS_HELP_STRING([--disable-numa], [disable NUMA/Node support in top]),
[disable_numa=yes], [])
@@ -203,7 +204,9 @@ if test "x$disable_numa" = x"yes"; then
else
AC_SEARCH_LIBS([dlopen], [dl], [],
[AC_MSG_ERROR([dynamic linking unavailable, circumvent with --disable-numa])])
+ DL_LIB="$ac_cv_search_dlopen"
fi
+AC_SUBST([DL_LIB])
AC_ARG_ENABLE([w-from],
AS_HELP_STRING([--enable-w-from], [enable w from field by default]),