summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Raghavan <arun@asymptotic.io>2020-07-23 19:36:11 -0400
committerArun Raghavan <arun@arunraghavan.net>2020-11-23 19:02:33 +0000
commitc442227c6bc64789cb4bd47dbd0b73b11e7a60e4 (patch)
treed8471da48f8e082912ee946b5a85736392d9ef1f /configure.ac
parentb546beef21d1918b7c08f2d1838ef6f32d7ead73 (diff)
downloadpulseaudio-c442227c6bc64789cb4bd47dbd0b73b11e7a60e4.tar.gz
glib-mainloop: Drop deprecated g_get_current_time() usage
This uses the year 2038-safe g_get_real_time() as recommended instead. Bumps GLib dependency to 2.28 as a result.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a519e63d7..caabef6ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -894,7 +894,7 @@ AC_ARG_ENABLE([glib2],
AS_HELP_STRING([--disable-glib2],[Disable optional GLib 2 support]))
AS_IF([test "x$enable_glib2" != "xno"],
- [PKG_CHECK_MODULES(GLIB20, [ glib-2.0 >= 2.4.0 ], HAVE_GLIB20=1, HAVE_GLIB20=0)],
+ [PKG_CHECK_MODULES(GLIB20, [ glib-2.0 >= 2.28.0 ], HAVE_GLIB20=1, HAVE_GLIB20=0)],
HAVE_GLIB20=0)
AS_IF([test "x$enable_glib2" = "xyes" && test "x$HAVE_GLIB20" = "x0"],