summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTanu Kaskinen <tanuk@iki.fi>2018-01-24 03:51:49 +0200
committerTanu Kaskinen <tanuk@iki.fi>2018-01-31 08:21:32 +0200
commitdfb0460fb4743aec047cdf755a660a9ac2d0f3fb (patch)
tree590e5273ed117b18ceb8ad89334f0ec110db9568 /configure.ac
parent6d7e057b3739c365964892296a9cf4fc075bc844 (diff)
downloadpulseaudio-dfb0460fb4743aec047cdf755a660a9ac2d0f3fb.tar.gz
memfd-wrappers: only define memfd_create() if not already defined
glibc 2.27 is to be released soon, and it will provide memfd_create(). If glibc provides the function, we must not define it ourselves, otherwise building fails due to conflict between the two implementations of the same function. BugLink: https://bugs.freedesktop.org/show_bug.cgi?id=104733
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0084c86e4..0eb44b08f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -610,6 +610,9 @@ AS_IF([test "x$enable_memfd" = "xyes" && test "x$HAVE_MEMFD" = "x0"],
[AC_MSG_ERROR([*** Your Linux kernel does not support memfd shared memory.
*** Use linux v3.17 or higher for such a feature.])])
+AS_IF([test "x$HAVE_MEMFD" = "x1"],
+ AC_CHECK_FUNCS([memfd_create]))
+
AC_SUBST(HAVE_MEMFD)
AM_CONDITIONAL([HAVE_MEMFD], [test "x$HAVE_MEMFD" = x1])
AS_IF([test "x$HAVE_MEMFD" = "x1"], AC_DEFINE([HAVE_MEMFD], 1, [Have memfd shared memory.]))