summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTanu Kaskinen <tanuk@iki.fi>2016-12-05 22:20:42 +0200
committerTanu Kaskinen <tanuk@iki.fi>2016-12-09 13:09:26 +0200
commitc81f3da53b908a05e6325b6bc0dfb4cd5b08f8ec (patch)
tree8bf9a5a256e16aa5dd7740398c801e70d4958b82 /configure.ac
parent6a786c93758b9cf2128938a8459c3387c0532a1e (diff)
downloadpulseaudio-c81f3da53b908a05e6325b6bc0dfb4cd5b08f8ec.tar.gz
remove module-xenpv-sink
The module doesn't build any more[1], and when starting to investigate the build failure, I asked the module author if he'd know something about the breakage. He said that he didn't know about backward compatibility problems with libxen, but more importantly, he said that the module probably doesn't have any users[2]. It doesn't make sense to keep maintaining a module that doesn't have users, so let's drop it. [1] https://bugs.freedesktop.org/show_bug.cgi?id=98793 [2] https://lists.freedesktop.org/archives/pulseaudio-discuss/2016-November/027172.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 0 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index 35f0011d2..95b599366 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1190,30 +1190,6 @@ AS_IF([test "x$with_soxr" = "xyes" && test "x$HAVE_SOXR" = "x0"],
AM_CONDITIONAL([HAVE_SOXR], [test "x$HAVE_SOXR" = "x1"])
AS_IF([test "x$HAVE_SOXR" = "x1"], AC_DEFINE([HAVE_SOXR], 1, [Have soxr]))
-#### Xen support (optional) ####
-
-AC_ARG_ENABLE([xen],
- AS_HELP_STRING([--disable-xen],[Disable optional Xen paravirtualized driver]))
-
-XEN_CFLAGS=
-XEN_LIBS=
-
-AS_IF([test "x$enable_xen" != "xno"],
- [
- HAVE_XEN=1
- AC_CHECK_HEADER(xenctrl.h, [], [HAVE_XEN=0])
- AC_CHECK_HEADER(xs.h, [], [HAVE_XEN=0])
- AC_CHECK_LIB(xenctrl, xc_interface_open, [XEN_LIBS="$XEN_LIBS -lxenctrl"], [HAVE_XEN=0])
- AC_CHECK_LIB(xenstore, xs_domain_open, [XEN_LIBS="$XEN_LIBS -lxenstore"], [HAVE_XEN=0])
- ],
- HAVE_XEN=0)
-
-AS_IF([test "x$enable_xen" = "xyes" && test "x$HAVE_XEN" = "x0"],
- [AC_MSG_ERROR([*** Xen development headers or libraries not found])])
-
-AC_SUBST(XEN_CFLAGS)
-AC_SUBST(XEN_LIBS)
-AM_CONDITIONAL([HAVE_XEN], [test "x$HAVE_XEN" = x1])
#### gcov support (optional) #####
@@ -1576,7 +1552,6 @@ AS_IF([test "x$HAVE_AVAHI" = "x1"], ENABLE_AVAHI=yes, ENABLE_AVAHI=no)
AS_IF([test "x$HAVE_JACK" = "x1"], ENABLE_JACK=yes, ENABLE_JACK=no)
AS_IF([test "x$HAVE_LIBASYNCNS" = "x1"], ENABLE_LIBASYNCNS=yes, ENABLE_LIBASYNCNS=no)
AS_IF([test "x$HAVE_LIRC" = "x1"], ENABLE_LIRC=yes, ENABLE_LIRC=no)
-AS_IF([test "x$HAVE_XEN" = "x1"], ENABLE_XEN=yes, ENABLE_XEN=no)
AS_IF([test "x$HAVE_DBUS" = "x1"], ENABLE_DBUS=yes, ENABLE_DBUS=no)
AS_IF([test "x$HAVE_UDEV" = "x1"], ENABLE_UDEV=yes, ENABLE_UDEV=no)
AS_IF([test "x$HAVE_SYSTEMD_DAEMON" = "x1"], ENABLE_SYSTEMD_DAEMON=yes, ENABLE_SYSTEMD_DAEMON=no)
@@ -1639,7 +1614,6 @@ echo "
Enable Jack: ${ENABLE_JACK}
Enable Async DNS: ${ENABLE_LIBASYNCNS}
Enable LIRC: ${ENABLE_LIRC}
- Enable Xen PV driver: ${ENABLE_XEN}
Enable D-Bus: ${ENABLE_DBUS}
Enable BlueZ 4: ${ENABLE_BLUEZ_4}
Enable BlueZ 5: ${ENABLE_BLUEZ_5}