summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig) <jan.steffens@gmail.com>2019-07-11 01:25:38 +0200
committerArun Raghavan <arun@arunraghavan.net>2019-07-25 16:53:01 +0000
commit8e98ed94939fe08269b97ee0fb15ec4afa7ddb4c (patch)
treefb7cf4ec34bd5112ddeea3a1b713783e1863db41 /meson.build
parent09231eaead5b957db8251ac1ec65e241dbd105ce (diff)
downloadpulseaudio-8e98ed94939fe08269b97ee0fb15ec4afa7ddb4c.tar.gz
meson: Fix library versioning to match Autotools
For ease of maintaining both build systems, use the same version info sequences as configure.ac. This should be simplified after Autotools has been dropped.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build43
1 files changed, 29 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index 47f26bfe3..1a504cc02 100644
--- a/meson.build
+++ b/meson.build
@@ -21,20 +21,35 @@ pa_version_major_minor = pa_version_major + '.' + pa_version_minor
pa_api_version = 12
pa_protocol_version = 33
-apiversion = '1.0'
-soversion = 0
-# FIXME: this doesn't actually do what we want it to
-# maintaining compatibility with the previous libtool versioning
-# current = minor * 100 + micro
-libversion = '@0@.@1@.0'.format(soversion, pa_version_minor.to_int() * 100 + pa_version_micro.to_int())
-
-# A simplified, synchronous, ABI-stable interface for client applications.
-# For the version x:y:z always will hold y=z.
-libpulse_simple_version = '1.1.1'
-
-# The ABI-stable GLib adapter for client applications.
-# For the version x:y:z always will hold y=z.
-libpulse_mainloop_glib_version = '0.5.0'
+# The stable ABI for client applications, for the version info x:y:z
+# always will hold y=z
+libpulse_version_info = [21, 0, 21]
+
+# A simplified, synchronous, ABI-stable interface for client
+# applications, for the version info x:y:z always will hold y=z
+libpulse_simple_version_info = [1, 1, 1]
+
+# The ABI-stable GLib adapter for client applications, for the version
+# info x:y:z always will hold y=z
+libpulse_mainloop_glib_version_info = [0, 5, 0]
+
+libpulse_version = '@0@.@1@.@2@'.format(
+ libpulse_version_info[0] - libpulse_version_info[2],
+ libpulse_version_info[0],
+ libpulse_version_info[1],
+)
+
+libpulse_simple_version = '@0@.@1@.@2@'.format(
+ libpulse_simple_version_info[0] - libpulse_simple_version_info[2],
+ libpulse_simple_version_info[0],
+ libpulse_simple_version_info[1],
+)
+
+libpulse_mainloop_glib_version = '@0@.@1@.@2@'.format(
+ libpulse_mainloop_glib_version_info[0] - libpulse_mainloop_glib_version_info[2],
+ libpulse_mainloop_glib_version_info[0],
+ libpulse_mainloop_glib_version_info[1],
+)
# Paths