summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Henningsson <david.henningsson@canonical.com>2015-03-24 10:29:13 +0100
committerDavid Henningsson <david.henningsson@canonical.com>2015-03-30 10:52:29 +0200
commit979f19a434733afba0480e2ba456cccc98362e05 (patch)
treebd60003344961fa9c107629cd5030b2f0a14334b /src/Makefile.am
parentf3ebf6b667b155f5fe6526bd70881c79e07d7874 (diff)
downloadpulseaudio-979f19a434733afba0480e2ba456cccc98362e05.tar.gz
lfe-filter: Enable LFE filter in the resampler
When enable-lfe-remixing is set, an LFE channel is present in the resampler's destination channel map but not in the source channel map, we insert a low-pass filter instead of just averaging the channels. Other channels will get a high-pass filter. In this patch, the crossover frequency is hardcoded to 120Hz (to be fixed in later patches). Note that in current state the LFE filter is - not very optimised - not rewind friendly (rewinding can cause audible artifacts) Signed-off-by: David Henningsson <david.henningsson@canonical.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 67f862770..302c532d2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -911,6 +911,9 @@ lib_LTLIBRARIES += libpulsecore-@PA_MAJORMINOR@.la
# Pure core stuff
libpulsecore_@PA_MAJORMINOR@_la_SOURCES = \
+ pulsecore/filter/lfe-filter.c pulsecore/filter/lfe-filter.h \
+ pulsecore/filter/biquad.c pulsecore/filter/biquad.h \
+ pulsecore/filter/crossover.c pulsecore/filter/crossover.h \
pulsecore/asyncmsgq.c pulsecore/asyncmsgq.h \
pulsecore/asyncq.c pulsecore/asyncq.h \
pulsecore/auth-cookie.c pulsecore/auth-cookie.h \